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Chapter 1 - Introduction
About Navicat

Navicat is a multi-connections Database Administration tool allowing you to connect to MySQL, MariaDB, MongoDB,
SQL Server, Oracle, PostgreSQL, SQLite, Redis and/or Snowflake, making database administration to multiple kinds of
database so easy. It can also manage cloud databases such as Amazon Redshift, Amazon RDS, Alibaba Cloud.
Features in Navicat are sophisticated enough to provide professional developers for all their specific needs, yet easy to
learn for users who are new to database server. With its well-designed Graphical User Interface(GUI), Navicat lets you

quickly and easily create, organize, access and share information in a secure and easy way.

Navicat is available on three platforms - Microsoft Windows, macOS and Linux. It can connect to local/remote servers,
providing several utility tools such as Cloud Collaboration, Data Modeling, Data Transfer, Data/Structure
Synchronization, Import/Export, Backup/Restore, Al Assistant, Bl, Data Generation, Data Dictionary, Data Profiling and

Automation.

For details, visit our website: https://www.navicat.com

Requirements

Supported Operating Systems

Windows

e  Microsoft Windows 7, Windows 8, Windows 8.1, Windows 10, Windows 11, Server 2012, Server 2016, Server
2019, Server 2022

macOS

e macOS 11 Big Sur, macOS 12 Monterey, macOS 13 Ventura, macOS 14 Sonoma, macOS 15 Sequoia
Linux
x86_64

e Debian 10, Debian 11, Debian 12, Ubuntu 20.04, Ubuntu 22.04, Ubuntu 24.04, Fedora 38, Fedora 39, Fedora
40, Linux Mint 20, Linux Mint 21, Deepin 20, KylinOS Desktop 10

aarch64

e Debian 11, Debian 12, Ubuntu 22.04, Ubuntu 24.04, Fedora 38, Fedora 39, Fedora 40, Linux Mint 20, Linux
Mint 21, KylinOS Desktop 10

Supported On-Premises Databases

e MySQL 3.23 or later
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e PostgreSQL 7.3 or later

e Oracle 8i or later

e SQLite2and 3

e SQL Server 2000 or later

e MariaDB 5.1 or later

e MongoDB 3.0 or later

e Redis 2.8 or later, Redis Cluster, Redis Sentinel, Microsoft Garnet

e OceanBase Community and Enterprise 3.1.0 or later (Enterprise Oracle Mode is not available in macOS
Edition)

e TiDB 7 or later

e Drizzle, OurDelta, Percona Server

Supported Cloud Databases

Amazon AWS

e Amazon Redshift

e Amazon Aurora for MySQL

e Amazon Aurora for PostgreSQL

e Amazon RDS for MySQL

e Amazon RDS for PostgreSQL

e Amazon RDS for Oracle

e Amazon RDS for SQL Server

e Amazon RDS for MariaDB

e Amazon DocumentDB

e Amazon ElastiCache for Redis

Google Cloud

e Google Cloud SQL for MySQL

e Google Cloud SQL for PostgreSQL
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e Google Cloud SQL for SQL Server

e (Google Memorystore (Redis)

Oracle Cloud

e Oracle Database Cloud Service

e Oracle MySQL Cloud Service

Microsoft

Microsoft Azure SQL Database

e Microsoft Azure Database for MySQL

e Microsoft Azure Database for PostgreSQL

e Microsoft Azure Database for MariaDB

e Microsoft Azure Cache for Redis

MongoDB Cloud Services

e MongoDB Atlas

Redis Enterprise Cloud

e Redis Enterprise Cloud

Alibaba Cloud

e Alibaba Cloud ApsaraDB RDS for MySQL

e Alibaba Cloud ApsaraDB RDS for PostgreSQL

e Alibaba Cloud ApsaraDB RDS for SQL Server

e Alibaba Cloud ApsaraDB for MongoDB

e Alibaba Cloud ApsaraDB for Redis

e Alibaba Cloud ApsaraDB for OceanBase (MySQL Mode)

e Alibaba Cloud PolarDB for MySQL

e Alibaba Cloud PolarDB for PostgreSQL

e Alibaba Cloud PolarDB for Xscale

Tencent Cloud
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e Tencent Cloud TencentDB for MySQL

e Tencent Cloud TencentDB for PostgreSQL

e Tencent Cloud TencentDB for SQL Server

e Tencent Cloud TencentDB for MariaDB

e Tencent Cloud TencentDB for MongoDB

e Tencent Cloud TencentDB for Redis

Huawei Cloud

Huawei Cloud RDS for MySQL

Huawei Cloud RDS for PostgreSQL

Huawei Cloud RDS for SQL Server

Huawei Cloud Document Database Service

Huawei Cloud Distributed Cache Service for Redis

Snowflake

Installation

We strongly suggest that you shut down any opened applications. This will help ensure a smooth installation.
Installation for Download Version

1. Download Navicat macOS version.

2. Open the .dmg file.

3. Drag Navicat to your Applications folder to install.

Registration

When the trial period is finished, Navicat requires a license key or a subscription plan to continue using the features.

Note: Perpetual License and Subscription Plan cannot be used at the same Navicat. Before changing the registration

method, you need to deactivate the license key or sign out your Navicat ID.

Perpetual License

If you have purchased a perpetual license, you will receive a license key for activating Navicat.
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In the Perpetual License section, paste your license key (16 digits) and click the Activate button. Navicat contacts our

licensing server to activate the license key. If the activation process is successful, the license key details are displayed.
Manual Activation

Manual activation is available when your computer does not have an internet connection. You will need another

computer with an internet connection to complete this activation process.
1. If the online activation is failed, click Manual Activation.
2. Copy the Request Code in the Copy the Request Code Here: box.

3. Open web browser on a computer with an internet connection and then go to

https://customer.navicat.com/manual_activate.php.

4. Paste/Enter the Request Code into the left box.

5. Click Get Activation Code.

6. Copy the generated Activation Code in the right box.

7. Go back to the computer where you are activating Navicat.

8. Paste the Activation Code into the Paste the Activation Code Here: box.
9. Click Activate.
Subscription Plan
If you have subscribed a plan, you can sign in your Navicat ID to use Navicat during the subscription term.
Note: Navicat ID is the Email address that you used to subscribe the plan.

In the Subscription section, provide your Navicat ID and Password. After signed in, the subscription plan details are

displayed.

Navicat contacts our licensing server once per hour to auto reload the plan by default. If you have updated your plan in

the portal site, you can use the Reload Plan button to force reloading the new plan.

Note: Each Navicat ID can connect to only one Navicat. If you sign in your Navicat ID in another Navicat, you will be

signed out from the current Navicat.

Migration / Upgrade

Migrate Navicat to a new computer
1. In Navicat, choose File -> Export Connections. The exported file (.ncx) contains all your connection settings.

2. Backup the exported file (.ncx).
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3. In Navicat, choose Navicat XXX -> Registration.

4. [Perpetual License] Click Deactivate to online deactivate the license key.

5. [Subscription Plan] Click Sign Out to sign out your Navicat ID.

6. Uninstall Navicat from the existing computer.

7. Re-install Navicat in the new computer.

8. Open Navicat and choose File -> Import Connections in the new computer to import the connection settings

(.ncx).

When a new connection is being established, Navicat will create a subfolder under Settings Location. Most files are

stored within this subfolder. To look for the path, control-click the connection and select Edit Connection -> Advanced

-> Settings Location.

Moreover, all your saved profiles are stored under the default path, e.g. ~/Library/Application Support/PremiumSoft

CyberTech/Navicat CC/Navicat Premium/Profiles.

Upgrade Navicat

If you want to upgrade an installed copy of Navicat to the latest release, please choose Navicat XXX -> Check for
Updates to start the Updater. It will automatically check your installed version. If there is a new version, simply follow
the steps in the Updater to upgrade your Navicat. It will replace your previous Navicat and your current settings will

remain unchanged.

Or, you can submit your registered email address on the Customer Center to download the latest version installer.

End-User License Agreement

Note: For the License Agreement of Navicat Cloud service, please click here.

IMPORTANT: THIS SOFTWARE END USER LICENSE AGREEMENT ("EULA") IS A LEGAL AGREEMENT
BETWEEN YOU (EITHER AN INDIVIDUAL OR, IF PURCHASED OR OTHERWISE ACQUIRED BY OR FOR AN
ENTITY, AN ENTITY) AND PREMIUMSOFT CYBERTECH LTD..READ IT CAREFULLY BEFORE COMPLETING THE
INSTALLATION PROCESS AND USING THE SOFTWARE. IT PROVIDES A LICENSE TO USE THE SOFTWARE
AND CONTAINS WARRANTY INFORMATION AND LIABILITY DISCLAIMERS. BY INSTALLING AND USING THE
SOFTWARE, YOU ARE CONFIRMING YOUR ACCEPTANCE OF THE SOFTWARE AND AGREEING TO BECOME
BOUND BY THE TERMS OF THIS AGREEMENT. IF YOU DO NOT AGREE TO BE BOUND BY THESE TERMS,
THEN DO NOT INSTALL THE SOFTWARE AND RETURN THE SOFTWARE TO YOUR PLACE OF PURCHASE.
THIS EULA SHALL APPLY ONLY TO THE SOFTWARE SUPPLIED BY PREMIUMSOFT CYBERTECH LTD.
HEREWITH REGARDLESS OF WHETHER OTHER SOFTWARE IS REFERRED TO OR DESCRIBED HEREIN.

1. Definitions

18


https://customer.navicat.com/
https://legal.navicat.com/navicatcloud/NavicatCloudLicenseAgreement.rtf

a. "Non-commercial Version" means a version of the Software, so identified, for use by i) the individual who is a
natural person and not a corporation, company, partnership or association or other entity or organization (ii) the
individual who is a student, faculty or staff member at an educational institution, and (iii) staff of a non-profit
organization or charity organization only. For purposes of this definition, "educational institution” means a
public or private school, college, university and other post secondary educational establishment. A non-profit
organization is an organization whose primary objective is to support an issue or matter of private interest or

public concern for non-commercial purposes.

b. "Not For Resale (NFR) Version" means a version, so identified, of the Software to be used to review and

evaluate the Software, only.
c. "PremiumSoft" means PREMIUMSOFT CYBERTECH LTD. and its licensors, if any.

d. "Software" means only the PremiumSoft software program(s) and third party software programs, in each case,
supplied by PremiumSoft herewith, and corresponding documentation, associated media, printed materials,

and online or electronic documentation.

e. "Unregistered version", "Trial version" or "Demo version" means an unregistered copy of the SOFTWARE
("UNREGISTERED SOFTWARE") which may be used by the USER for evaluation purposes for a period of
fourteen (14) days following the initial installation of the UNREGISTERED SOFTWARE. At the end of the trial
period ("TRIAL PERIOD"), the USER must either register the SOFTWARE or remove it from his system. The
UNREGISTERED SOFTWARE may be freely copied and distributed to other users for their evaluation.

f.  "Navicat Premium Lite" means a free-to-use version of the Software with limited features, identified as "Lite".
2. License Grants
The licenses granted in this Section 2 are subject to the terms and conditions set forth in this EULA:

a. Subject to Section 2(b), you may install and use the Software on a single computer; OR install and store the
Software on a storage device, such as a network server, used only to install the Software on your other
computers over an internal network, provided you have a license for each separate computer on which the
Software is installed and run. Except as otherwise provided in Section 2(b), a license for the Software may not

be shared, installed or used concurrently on different computers.

b. In addition to the single copy of the Software permitted in Section 2(a), the primary user of the computer on
which the Software is installed may make a second copy of the Software and install it on either a portable

computer or a computer located at his or her home for his or her exclusive use, provided that:

A. the second copy of the Software on the portable or home computer (i) is not used at the same time as
the copy of the Software on the primary computer and (ii) is used by the primary user solely as allowed

for such version or edition (such as for educational use only),

B. the second copy of the Software is not installed or used after the time such user is no longer the primary

user of the primary computer on which the Software is installed.
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In the event the Software is distributed along with other PremiumSoft software products as part of a suite of
products (collectively, the "Studio"), the license of the Studio is licensed as a single product and none of the
products in the Studio, including the Software, may be separated for installation or use on more than one

computer.

You may make one copy of the Software in machine-readable form solely for backup purposes. You must
reproduce on any such copy all copyright notices and any other proprietary legends on the original copy of the

Software. You may not sell or transfer any copy of the Software made for backup purposes.

You agree that PremiumSoft may audit your use of the Software for compliance with these terms at any time,
upon reasonable notice. In the event that such audit reveals any use of the Software by you other than in full
compliance with the terms of this Agreement, you shall reimburse PremiumSoft for all reasonable expenses

related to such audit in addition to any other liabilities you may incur as a result of such non-compliance.

Your license rights under this EULA are non-exclusive.

3. License Restrictions

a.

Other than as set forth in Section 2, you may not make or distribute copies of the Software, or electronically

transfer the Software from one computer to another or over a network.

You may not alter, merge, modify, adapt or translate the Software, or decompile, reverse engineer,

disassemble, or otherwise reduce the Software to a human-perceivable form.

Unless otherwise provided herein, you may not rent, lease, or sublicense the Software.

Other than with respect to a Trial / Demo Version, Lite Version or a Not For Resale Version of the Software,
you may permanently transfer all of your rights under this EULA only as part of a sale or transfer, provided you
retain no copies, you transfer all of the Software (including all component parts, the media and printed
materials, any upgrades, this EULA, the serial numbers, and, if applicable, all other software products provided
together with the Software), and the recipient agrees to the terms of this EULA. If the Software is an upgrade,
any transfer must include all prior versions of the Software from which you are upgrading. If the copy of the
Software is licensed as part of the whole Studio (as defined above), the Software shall be transferred only with
and as part of the sale or transfer of the whole Studio, and not separately. You may retain no copies of the
Software. You may not sell or transfer any Trial / Demo Version, Lite Version or Not For Resale Version of the

Software.

Unless otherwise provided herein, you may not modify the Software or create derivative works based upon the

Software.

Non-commercial Versions of the Software may not be used for, or distributed to any party for, any commercial

purpose.

Unless otherwise provided herein, you shall not

A. in the aggregate, install or use more than one copy of the Trial / Demo Version of the Software,
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h.

B. download the Trial / Demo Version of the Software under more than one username,

C. alter the contents of a hard drive or computer system to enable the use of the Trial / Demo Version of the
Software for an aggregate period in excess of the trial period for one license to such Trial / Demo

Version,

D. disclose the results of software performance benchmarks obtained using the Trial / Demo Version or

Lite Version to any third party without PremiumSoft prior written consent, or

E. use the Trial / Demo Version of the Software for a purpose other than the sole purpose of determining
whether to purchase a license to a commercial or education version of the software; provided, however,
notwithstanding the foregoing, you are strictly prohibited from installing or using the Trial / Demo Version

or Lite Version of the Software for any commercial training purpose.

For Navicat Premium Lite: For avoidance of doubt, Navicat Premium Lite is licensed, not sold. Under this EULA,
PremiumSoft grants you the right to 1) download [one copy] of the software, and 2) install and run [one
instance] of the software on your [one device], whether physical or virtual with an internal storage device
capable of running the software, so long as you comply with all the terms of this EULA.

If you were in possession of multiple software versions, you may only install and run [one] of those versions at
a time. If you use the software on more than one physical or virtual device, you must obtain a separate license
for each instance.

[Commercial Use]

The number of users at any time within a business, whether incorporated or not, shall not exceed [five persons].
To use the software on more than one device, you are required to obtain a dedicated license and you may
allow up to [five other devices] to access the software installed on the licensed device for commercial use.
[Non-Commercial Use]

Users qualified for PremiumSoft's Non-Commercial Licensing Program, subject to the conditions of the

program as detailed in Navicat Non-Commercial Licensing Program

(www.navicat.com/en/store/non-commercial), are granted the right to download, install, run, and use the

software.

You may only use the Not for Resale Version of the Software to review and evaluate the Software.

You may receive the Software in more than one medium but you shall only install or use one medium.
Regardless of the number of media you receive, you may use only the medium that is appropriate for the

server or computer on which the Software is to be installed.

You may receive the Software in more than one platform but you shall only install or use one platform.

You shall not use the Software to develop any application having the same primary function as the Software.

In the event that you fail to comply with this EULA, PremiumSoft may terminate the license and you must
destroy all copies of the Software (with all other rights of both parties and all other provisions of this EULA

surviving any such termination).

This program may include Oracle Instant Client (OCI). You agree that you shall
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1. not use of the Oracle Instant Client to the business operations;

2. notassign, give, or transfer the Oracle Instant Client or an interest in them to another individual or entity;

a. make the Programs available in any manner to any third party for use in the third party's

business operations; and

b. title to the Programs from passing to the end user or any other party;

3. not reverse engineer, disassemble or decompilation the Oracle Instant Client and duplicate the
Programs except for a sufficient number of copies of each Program for your licensed use and one copy

of each Program media;

4. discontinue use and destroy or return to all copies of the Oracle Instant Client and documentation after

termination of the Agreement;

5. not publish any results of benchmark tests run on the Programs;

6. comply fully with all relevant export laws and regulations of the United States and other applicable
export and import laws to assure that neither the Oracle Instant Client, nor any direct product thereof,

are exported, directly or indirectly, in violation of applicable laws;

7. allow PremiumSoft to audit your use of the Oracle Instant Client;

4. Upgrades

If this copy of the Software is an upgrade from an earlier version of the Software, it is provided to you on a license
exchange basis. You agree by your installation and use of such copy of the Software to voluntarily terminate your
earlier EULA and that you will not continue to use the earlier version of the Software or transfer it to another person or

entity unless such transfer is pursuant to Section 3.

5. Ownership

The foregoing license gives you limited license to use the Software. PremiumSoft and its suppliers retain all rights, title
and interest, including all copyright and intellectual property rights, in and to, the Software (as an independent work and
as an underlying work serving as a basis for any application you may develop), and all copies thereof. All rights not
specifically granted in this EULA, including Federal and International Copyrights, are reserved by PremiumSoft and its

suppliers.

6. LIMITED WARRANTY AND DISCLAIMER

a. Except with respect to Trial / Demo Version, Lite Version and Not For Resale Version of the Software,
PremiumSoft warrants that, for a period of thirty (30) days from the date of delivery (as evidenced by a copy of
your receipt): the physical media on which the Software is furnished will be free from defects in materials and
workmanship under normal use. The Software is provided "as is". PremiumSoft makes no warranties, express

or implied, arising from course of dealing or usage of trade, or statutory, as to any matter whatsoever.
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b. PremiumSoft provides no remedies or warranties, whether express or implied, for Trial / Demo version, Lite
version and the Not for Resale version of the Software. Trial / Demo version, Lite version and the Not for

Resale version of the Software are provided "as is".

c. Except as set Forth in the foregoing limited warranty with respect to software other than Trial/ Demo version,
Lite version and Not for Resale version, PremiumSoft and its suppliers disclaim all other warranties and
representations, whether express, implied, or otherwise, including the warranties of merchantability or fitness
for a particular purpose. Also, there is no warranty of non-infringement and title or quiet enjoyment.
PremiumSoft does not warrant that the Software is error-free or will operate without interruption. The Software
is not designed, intended or licensed for use in hazardous environments requiring fail-safe controls, including
without limitation, the design, construction, maintenance or operation of nuclear facilities, aircraft navigation or
communication systems, air traffic control, and life support or weapons systems. PremiumSoft specifically

disclaims any express or implied warranty of fithess for such purposes.

d. |If applicable law requires any warranties with respect to the Software, all such warranties are limited in duration

to thirty (30) days from the date of delivery.

e. No oral or written information or advice given by PremiumSoft, its dealers, distributors, agents or employees

shall create a warranty or in any way increase the scope of ANY warranty PROVIDED HEREIN.

7. LIMITATION OF LIABILITY

(a) Neither PremiumSoft nor its suppliers shall be liable to you or any third party for any indirect, special, incidental,
punitive or consequential damages (including, but not limited to, damages for the inability to use equipment or access
data, loss of business, loss of profits, business interruption or the like), arising out of the use of, or inability to use, the
Software and based on any theory of liability including breach of contract, breach of warranty, tort (including
negligence), product liability or otherwise, even if PremiumSoft or its representatives have been advised of the

possibility of such damages.

8. Third Party Software

The Software may contain third party software which requires notices and/or additional terms and conditions. By

accepting this EULA, you are also accepting the additional terms and conditions of the third party software.

9. General

No PremiumSoft dealer, agent or employee is authorized to make any amendment to this EULA.

This EULA contains the complete agreement between the parties with respect to the subject matter hereof, and
supersedes all prior or contemporaneous agreements or understandings, whether oral or written. You agree that any
varying or additional terms contained in any purchase order or other written notification or document issued by you in
relation to the Software licensed hereunder shall be of no effect. The failure or delay of PremiumSoft to exercise any of
its rights under this EULA or upon any breach of this EULA shall not be deemed a waiver of those rights or of the

breach.
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If any provision of this EULA shall be held by a court of competent jurisdiction to be contrary to law, that provision will
be enforced to the maximum extent permissible, and the remaining provisions of this EULA will remain in full force and
Effect.

10. Basis of Bargain

The Limited Warranty and Disclaimer and Limited Liability set forth above are fundamental elements of the basis of the
agreement between PremiumSoft and you. PremiumSoft would not be able to provide the Software on an economic
basis without such limitations. Such Limited Warranty and Disclaimer and Limited Liability inure to the benefit of

PremiumSoft's licensors.

11. Term

By downloading and/or installing this SOFTWARE, the Licensor agrees to the terms of this EULA.

This license is effective until terminated. Licensor has the right to terminate your License immediately if you fail to

comply with any term of this License.

"as is". Licensor makes no warranties, express or implied, arising from course of dealing or usage of trade, or statutory,
as to any matter whatsoever. In particular, any and all warranties or merchantability, fithess for a particular purpose or

non-infringement of third party rights are expressly excluded.

12. License Termination

Without prejudice to any other rights, PremiumSoft may terminate this EULA if you fail to comply with the terms and

conditions of this EULA. In such event, you must destroy all copies of the software and all of its component parts.

13. Governing Law

This License will be governed by the laws in force in Hong Kong. You hereby consent to the non-exclusive jurisdiction

and venue sitting in Hong Kong to resolve any disputes arising under this EULA.

Should you have any questions concerning the validity of this License, please contact: licensing@navicat.com. If you

desire to contact the Licensor for any other reason, please contact support@navicat.com.

PremiumSoft and other trademarks contained in the Software are trademarks or registered trademarks of PremiumSoft
CyberTech Ltd. in the United States and/or other countries. Third party trademarks, trade names, product names and
logos may be the trademarks or registered trademarks of their respective owners. You may not remove or alter any
trademark, trade names, product names, logo, copyright or other proprietary notices, legends, symbols or labels in the
Software. This EULA does not authorize you to use PremiumSoft or its licensors names or any of their respective

trademarks.
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Chapter 2 - User Interface
Main Window

The Main Window consists of several toolbars and panes for you to work on connections, database objects and

advanced tools.

Hint: Navicat has added support for the system-wide dark mode.
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@ Main Toolbar

The Main Toolbar allows you to access basic objects and features, such as connections, users, tables, collections,

backup, automation and more. If the Main Toolbar is hidden, choose View -> Show Toolbar from the menu bar.

@ Navigation Pane

The Navigation Pane is the basic way to navigate with connections, databases and database objects. If the Navigation

Pane is hidden, choose View -> Navigation Pane -> Show Navigation Pane from the menu bar.

(3) Tab Bar

The Tab Bar allows you to switch among the tabbed windows on the Object Pane. You can choose to always display
pop-ups on a new tab, or to always display them in a new window. If you have multiple tabs open, you can use
COMMAND-{ or COMMAND-} to easily switch to other tabs. Control-click a tab to add it to favorite list or startup list.
See also Settings.

@ Object Toolbar

The Object Toolbar provides other controls that you can use to manipulate the objects.

@ Object Pane
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The Object Pane displays a list of objects (such as tables, collections, views, queries) and the tabbed window forms.

Use the = Detail and ¥ ER Diagram buttons to change the view of the Objects tab.
(&) Information Pane

The Information Pane shows the detailed object information, project activities, the DDL of database objects, object
dependencies, membership of users/roles and preview. If the Information Pane is hidden, choose View -> Information

Pane -> Show Information Pane from the menu bar.
(7) status Bar

The Status Bar displays the current window's status information. To view or hide the Status Bar, choose View -> Show

Status Bar from the menu bar.

Navigation Pane

The Navigation pane employs tree structure which allows you to take action upon the database and their objects
through their pop-up menus quickly and easily. If the Show objects under schema in navigation pane option is
checked at the Settings window, all database objects are also displayed in the pane. To connect to a database or

schema, simply double-click it in the pane.

After logged in Navicat Cloud or On-Prem Server, you can find it in the Navigation pane, and all connections stored

locally will be located under the My Connections section.

Table elements, such as fields, indexes and foreign keys, are display under each table. Click the arrow to the left of the
table name to expand the list. If the elements are hidden, enable the Show objects under table option in the Settings

window.

You can simply rename a field by using the pop-up menu, or you can double-click an element to open the table

designer.

If you want to hide the group structure in the Navigation pane, choose View -> Navigation Pane -> Flatten

Connection.

If the Navigation pane is hidden, choose View -> Navigation Pane -> Show Navigation Pane.

Filter Connections

Entering a search string in the Search text box will only show items containing the string. All groups, opened

connections and objects that containing search result will also automatically expand to show the filtered results.

The = and ¥ icons on the right of the text box let you quickly filter for specific connection types and venders, active

objects or starred connections.

Object Pane

In the Objects tab, you can use the Detail and # ER Diagram buttons to change the object view.
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If you want to hide the group structure in Detail view, choose View -> Flatten Object List from the menu bar.

Detail View

Detail view shows the name and several properties of objects in columns. To change the display columns of properties,
choose View -> Choose Columns from the menu bar and choose display columns for different objects from the

pop-up window.

ER Diagram View (Available only in Navicat Premium, Enterprise and Standard Edition)

Note: Available only for MySQL, Oracle, PostgreSQL, SQLite, SQL Server and MariaDB. Only tables provide ER

Diagram view.

An ER diagram will be generated automatically if the selected database/schema contains tables. ER diagram files are

stored under Settings Location.
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@ Diagram Canvas

Display table fields and relationships between tables in a database/schema graphically.

Add a Foreign Key

Click CP from the object toolbar. Drag and drop a field from the child table to the parent table.

Edit or Delete a Foreign Key

Control-click a relation line and select Design Foreign Key or Delete Foreign Key from the pop-up menu.

Note: Double-click a table in the ER Diagram view will open the Table Designer, while double-click a table in the List or

Detail view will open the Table Viewer.

@ Overview
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To zoom in or zoom out the selected area of the diagram, adjust the slider of the Overview. Same effect can be

achieved with keyboard shortcuts:
Zoom In: [COMMAND-Mousewheel up]
Zoom Out: [COMMAND-Mousewheel down]

Zoom Reset: [COMMAND-0]

(3) Bottom Toolbar

Button Description
C Refresh - Refresh the ER diagram.

Regenerate ER Diagram - Regenerate the ER diagram with using the auto

layout feature.

[ Switch the cursor to the Select mode.

M Switch the cursor to the hand mode for moving the diagram. Or, you can press
and hold the SPACE key, then move the diagram.

& Add a relation between two table fields. Click this button, and then drag and
drop a field from the child table to the parent table.

& Set the color of the selected tables or relations.

5% Automatically arrange all tables or selected tables on the canvas.

o Export the ER diagram to a PNG file.

(] Preview the diagram in a fullscreen mode.

Size Select a paper size from the drop-down list. The corresponding paper size will

reflect in the Overview pane.

Information Pane

The Information Pane shows the detailed object information, project activities, the DDL of database objects, object
dependencies, membership of users/roles and preview. If the Information Pane is hidden, choose View -> Information

Pane -> Show Information Pane from the menu bar.

You can select any connections, objects or projects, and then select the corresponding buttons on the Information

Pane.

Button Description

@ General - Show the general information of the object/project.

A Al Assistant - Chat with Al assistant.

L0 Preview - Show the SQL statements in the query.

DDL - Show the DDL statements of the object. Press COMMAND-F to open the
search box.

s Using - Show the objects that the selected object depends on.
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Objects - Show the objects in the tablespace.

Member Of - Show the roles that the user or the role assigned to.

=1 Used By - Show the objects that depend on the selected object.
Members - Show the members of the role.

() Code Snippet - Show all built-in and custom code snippets.

= & Identifiers - Show all available tables, collections, views or fields in the selected
database or schema.
Field - Show the information of the selected field in Table Viewer.

o Privileges - Show the privileges granted to the user.

@ Project - Show the project members and the project activities done by the
members. Click + to add members to the project.

&0 Type Color - Set the color of particular types for highlighting cells in Grid View.
(Available only for MongoDB)

‘B Pub/Sub Info - Show which channels are active on the Redis server.
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Chapter 3 - Collaboration

About Collaboration

Navicat allows you to synchronize connection settings, queries, aggregation pipelines, snippets, model workspaces, Bl
workspaces and virtual group information from Navicat, other Navicat family members, different machines and different
platforms. You can use Navicat Cloud to host the files. Or, if you have installed our another product, Navicat On-Prem

Server, in your environment, you can hosts everything in-house.

Our collaboration feature allows you to give your teammates access to your projects when they log into their accounts.
That way, you and your teammates can work on the same project without revealing your username and password. You

can even choose to restrict the type of access your teammates have to your project.

Manage Cloud

Navicat Cloud

Navicat Cloud is a cloud service provided by PremiumSoft for synchronizing connection settings, queries, aggregation

pipelines, snippets, model workspaces, Bl workspaces and virtual group information.

Navicat Cloud could not connect and access your databases. By which it means, it could only store your connection
settings, queries, aggregation pipelines, snippets, model workspaces, Bl workspaces and virtual group information; your

database passwords and data (e.g. tables, views, etc) will not be stored to Navicat Cloud.

Note: You can only sign in to one Navicat Cloud account in the software. PremiumSoft will keep all synchronized files
strictly confidential, and all employees are prohibited from viewing/accessing content of files you may store in your

Navicat Cloud account.
Create Navicat Cloud Account
1. Inthe menu bar, choose Navicat XXX -> Manage Cloud.
2. In the Manage Cloud window, select Navicat Cloud.
3. Click Create Navicat ID.
4. Enter the required information and click Sign Up. A verification email will send to your email address.
5. Click the link in the email to verify the new account.
Hint: You can sign in with the same Navicat ID you use for the Navicat Customer Center.
Sign In Navicat Cloud
1. Inthe menu bar, choose Navicat XXX -> Manage Cloud.

2. In the Manage Cloud window, select Navicat Cloud.
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3. Enter your Navicat ID and Password.
4. Click Sign In.

5. If you enabled two-step verification in Navicat Cloud Portal, a code will be sent to your phone via your mobile

app. Enter the received code to sign in.

Sign Out Navicat Cloud

1. In the main window, control-click Navicat Cloud and select Close All Connections to close all connections

under Navicat Cloud.
2. Atthe top right, click your avatar.
3. Inthe Manage Cloud window, select Navicat Cloud.
4. Click Sign Out.
View Usage
1. Atthe top right, click your avatar.
2. In the Manage Cloud window, select Navicat Cloud.
3. Your usage and current plan will be shown.
Change Your Picture
1. At the top right, click your avatar.
2. In the Manage Cloud window, select Navicat Cloud.
3. Click your avatar.

4. Choose an image file.

Manage Your Account

You can change your password, enable Two-Step Verification, upgrade Cloud Plan, etc in Navicat Cloud Portal.
1. At the top right, click your avatar.
2. In the Manage Cloud window, select Navicat Cloud.
3. Click Manage Account.

4. A web browser will automatically open up to Navicat Cloud Portal.
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On-Prem Server

Navicat On-Prem Server is an on-premise solution that provides you with the option to host a cloud environment for
storing Navicat objects (connection settings, queries, aggregation pipelines, snippets, model workspaces, BI

workspaces and virtual group information) internally at your location.
Before you can add an On-Prem Server, you must first set up Navicat On-Prem Server in your environment.
Note: You can add multiple On-Prem Server in the software.
Add New On-Prem Server
1. Inthe menu bar, choose Navicat XXX -> Manage Cloud.
2. In the Manage Cloud window, click + New On-Prem Server -> New On-Prem Server.

3. Enter your On-Prem Server login information.

Option Description
Host The host name or IP address of your On-Prem Server.
Port The port number of your On-Prem Server.

Verify Server Certificate | Enable this option to verify the server certificates.

Enable Push Navicat receives a silent push notification whenever its files stored
Synchronization in your On-Prem Server changes.
4. Click OK.

Add New On-Prem Server with URI

1. Inthe menu bar, choose Navicat XXX -> Manage Cloud.

2. In the Manage Cloud window, click + New On-Prem Server -> New On-Prem Server with URI.

3. Paste your On-Prem Server URI.

4. Click OK.

Note: The URI can be copied from your On-Prem Server portal site.

Sign In On-Prem Server

1. Inthe menu bar, choose Navicat XXX -> Manage Cloud.

2. In the Manage Cloud window, select the On-Prem Server.

3. Enter your Username and Password.

4. Click Sign In.
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5. If you enabled two-step verification, a code will be sent to you via the verification method you have selected.

Enter the received code to sign in.

Sign Out On-Prem Server

1. In the main window, control-click the On-Prem Server and select Close All Connections to close all

connections in your server.

2. Atthe top right, click your avatar.

3. Inthe Manage Cloud window, select the On-Prem Server.

4. Click Sign Out.

Edit On-Prem Server

1. In the main window, control-click the On-Prem Server and select Close All Connections to close all

connections in your server.

2. Atthe top right, click your avatar.

3. In the Manage Cloud window, select the On-Prem Server.

4. Click Sign Out.

5. Control-click your server and select Edit On-Prem Server.

6. Edit the On-Prem Server information.

7. Sign in your server.

Rename On-Prem Server

1. In the main window, control-click the On-Prem Server and select Close All Connections to close all

connections in your server.

2. Atthe top right, click your avatar.

3. Inthe Manage Cloud window, select the On-Prem Server.

4. Click Sign Out.

5. Control-click your server and select Rename.

6. Enter the name to describe your On-Prem Server.

7. Signin your server.

Remove On-Prem Server
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1. In the main window, control-click the On-Prem Server and select Close All Connections to close all

connections in your server.
2. Atthe top right, click your avatar.
3. In the Manage Cloud window, select the On-Prem Server.
4. Click Sign Out.
5. Control-click your server and select Remove On-Prem Server.
6. Click Delete.
View Usage
1. At the top right, click your avatar.
2. In the Manage Cloud window, select the On-Prem Server.
3. Your usage will be shown.
Change Your Picture
1. Atthe top right, click your avatar.
2. In the Manage Cloud window, select the On-Prem Server.
3. Click your avatar.
4. Choose an image file.
Manage Your Account
You can change your password, enable Two-Step Verification, etc in your On-Prem Server web portal.
1. At the top right, click your avatar.
2. In the Manage Cloud window, select the On-Prem Server.
3. Click Manage Account.
4. A web browser will automatically open up to your On-Prem Server web portal.

Push Synchronization

Push Synchronization enables Navicat to receive a silent push notification whenever the files stored in Navicat Cloud or

On-Prem Server changes.

Enable Push Synchronization
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1. Atthe top right, click your avatar.
2. In the Manage Cloud window, control-click Navicat Cloud or your On-Prem Server.
3. Turn on Enable Push Synchronization.
Disable Push Synchronization
1. At the top right, click your avatar.
2. Turn off Enable Push Synchronization.

Cache and Local Copies

When you logged into Navicat Cloud or your On-Prem Server, Navicat saves the cloud object files and some

information in the local computer. The cache and local copies use to make sure your changes are saved in the cloud.
Clear Cache and Local Copies
1. At the top right, click your avatar.
2. In the Manage Cloud window, select Navicat Cloud or your On-Prem Server.
3. Click Sign Out.
4. Control-click Navicat Cloud or your On-Prem Server and select Clear Cache and Local Copies.
5. Click Clear.
Show In Finder
1. In the main window, select Navicat Cloud or your On-Prem Server.
2. Open your project, connection, database and/or schema.
3. Click the Query, Model or Bl icon.

4. Control-click anywhere in the Objects tab and select Show In Finder.

Projects
Work With Projects

A project is a way to structure and organize Navicat objects. You can put related objects in one project, and then share

the project with other accounts for collaboration if necessary.

Create New Projects

1. In the main window, control-click Navicat Cloud or your On-Prem Server.
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2. Select New Project.
3. Enter the name of the new project.
4. Click OK.
Manage Existing Projects
To rename a project
1. In the main window, control-click the project and select Rename.
2. Enter a new project name.
Note: Only the project owner and the members with the Can Manage & Edit right can rename the project.
To delete a project
1. In the main window, control-click the project and select Delete Project.
2. Click Delete.
Note: Only the project owner can delete the project.
Note: Before you delete the project, you must remove all objects in the project.
To quit a project
1. In the main window, control-click the project and select Quit Project.

2. Click Quit.

Manage Members
Add Members
1. In the main window, control-click the project and select Manage Members.
2. Click Add Members.
3. [Navicat Cloud] Enter the member's Navicat ID and press ENTER.
4. [On-Prem Server] Check the boxes of the users that you want to add.

5. Select the member right.

6. Click Add.
Member Rights Privileges
Can Manage & Edit Read Objects, Write Objects, Manage Members and Rename
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Projects

Can Edit Read Objects and Write Objects

Can View Read Objects

Manage Existing Members

To edit the right of a member

1. In the main window, control-click the project and select Manage Members.

2. Use the drop-down menu next to the member to change the right.

3. Click Apply.

To remove a member from a project

1. In the main window, control-click the project and select Manage Members.

2. Click the X icon next to the member.

3. Click Apply.
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Chapter 4 - Connection

About Connection

To start working with your server in Navicat, you should first establish a connection or several connections using the
Connection window. If you are new to the server or 'Net in general' and are not quite sure how things work, you may

want to look at:

e MySQL User Manual

Oracle Database Documentation

PostgreSQL User Manual

SQLite User Manual

Microsoft SQL documentation

MariaDB Documentation

MongoDB Manual

Redis Documentation

Snowflake Documentation

Create Connection

1. In the main window, click #% Connection.

2. In the New Connection window, select your server type and click Next.
3. Enter the necessary information.

4. Click OK.

Note: Navicat authorizes you to make connection to remote servers running on different platforms (i.e. Windows,
macOS, Linux and UNIX), and supports PAM, Kerberos and LDAP authentication. Kerberos is only available in Navicat

Premium, Enterprise and Standard Editon.

Create Connection with URI
1. In the main window, click 5% Connection.
2. In the New Connection window, click New Connection with URI.

3. Paste your Navicat URI or MongoDB URI.

4. Click Apply.
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5. Navicat automatically fills out the options in the connection window. Modify your connection information if

necessary.
6. Click OK.
Hint: The Navicat URI can be copied from the Edit Connection window.
Edit Connection Settings
1. In the main window, control-click your connection and select Edit Connection.
2. In the Edit Connection window, modify your connection information.
3. Click OK.
Hint: You can view / copy your Navicat URI or MongoDB URI by clicking URI.

Move / Copy Connection To Project

If you have logged in to Navicat Cloud or On-Prem Server, you can synchronize the connection in My Connections to a

project.
1. Control-click a connection under My Connections and select Move Connection To or Copy Connection To.
2. Select an existing project or create a new project.
3. Choose whether to include all queries and virtual groups in the connection and click OK.
4. The connection will be moved or copied to the project.
Hint: You can move / copy a connection in a project to My Connections in a similar way.

Flush MySQL/MariaDB Connection

To clear or reload various internal caches, flush tables, or acquire locks, control-click your connection in the Navigation
pane and select Flush and choose the flush option. You must have the RELOAD privilege to use this feature.

Manage Azure SQL Database Firewall Rules

You cannot connect to Azure SQL Database until you have granted your client IP access. To access Azure SQL
Database from your computer, ensure that your firewall allows outgoing TCP communication on TCP port 1433. You

must have at least one firewall rule before you can connection to Azure SQL Database.

To manage the Firewall Rule settings, control-click your Azure SQL Database connection in the Navigation pane and

select SQL Azure Firewall Rules. Add a new rule by providing an IP address range.

Testing Account

Navicat provides evaluated accounts for testing purpose.
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MySQL

¢ Host: server1.navicat.com

Port: 4406

e User Name: navicat

* Password: testnavicat
PostgreSQL

* Host: server1.navicat.com

e Port: 5432

e Initial Database: HR

e User Name: navicat

¢ Password: testnavicat

General Settings

MySQL / MariaDB

To successfully establish a new connection to local/remote server - no matter via SSL, SSH or HTTP, set the database
login information in the General tab. If your Internet Service Provider (ISP) does not provide direct access to its server,

Secure Tunneling Protocol (SSH) / HTTP is another solution.

Option Description
Connection Name Enter a friendly name to best describe your connection.
Add To After you logged in Navicat Cloud or On-Prem Server, you can choose to

save the connection to My Connections or a project.

Host A host name where the database is situated or the IP address of the server.
Endpoint The Endpoint for connecting to the Amazon Web Services instance.
Port A TCP/IP port for connecting to the database server.
User Name User name for connecting to the database server.
Password Password for connecting to the database server.
Oracle

To successfully establish a new connection to local/remote server - no matter via SSH, set the database login
information in the General tab. If your Internet Service Provider (ISP) does not provide direct access to its server,

Secure Tunneling Protocol (SSH) is another solution.

Option Description
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Connection Name

Enter a friendly name to best describe your connection.

Add To

After you logged in Navicat Cloud or On-Prem Server, you can choose to

save the connection to My Connections or a project.

Connection Type

Basic - In Basic mode, it connects to Oracle through the Oracle Call Interface
(OCl).
TNS - In TNS mode, it connects to Oracle server using an alias entry from a

tnsnames.ora file through the Oracle Call Interface (OCI).

Host A host name where the database is situated or the IP address of the server.
Endpoint The Endpoint for connecting to the Amazon Web Services instance.
Port A TCP/IP port for connecting to the database server.

Service Name

Enter the Service Name or SID. Select the corresponding radio button.

Role

Indicate that the database user is connecting with either the Default,
SYSOPER or SYSDBA system privilege.

OS authentication

Use OS user login credentials to authenticate database users.

User Name

User name for connecting to the database server.

Password

Password for connecting to the database server.

Note: OCI is an application programming interface that allows an application developer to use a third-generation
language's native procedure or function calls to access the Oracle database server and control all phases of SQL
statement execution. OCl is a library of standard database access and retrieval functions in the form of a dynamic-link

library. See also: Settings

PostgreSQL

To successfully establish a new connection to local/remote server - no matter via SSL, SSH or HTTP, set the database
login information in the General tab. If your Internet Service Provider (ISP) does not provide direct access to its server,

Secure Tunneling Protocol (SSH) / HTTP is another solution.

Option Description

Connection Name Enter a friendly name to best describe your connection.

Add To