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Chapter 1 - Introduction
About Navicat Charts Creator
Navicat Charts Creator is a powerful and easy-to-use GUI tool for creating and manipulating charts. It enables users
to create visual representations of your database data.
Navicat Charts Creator is available on three platforms - Microsoft Windows, macOS and Linux. Here are some
highlights of Navicat Charts Creator:
•

Support more than 20 chart types.

•

Customize multiple pages dashboard.

•

Visualize live data.

•

Add interactive controls.

•

Support Navicat Cloud and Navicat On-Prem Server.

For details, visit our website: https://www.navicat.com

System Requirements
Windows
•

Microsoft Windows 7, Windows 8, Windows 8.1, Windows 10, Windows 11, Server 2012, Server 2016, Server
2019, Server 2022

macOS
•

macOS 10.14 Mojave, macOS 10.15 Catalina, macOS 11 Big Sur, macOS 12 Monterey

Linux
•

Debian 9, Debian 10, Debian 11, Ubuntu 18.04, Ubuntu 20.04, Ubuntu 22.04, Fedora 33, Fedora 34, Fedora
35, Linux Mint 19, Linux Mint 20, Linux Mint 21, Deepin 20

Supported On-Premises Databases
•

MySQL 3.23 or later, Drizzle, OurDelta, Percona Server

•

PostgreSQL 7.3 or later

•

Oracle 8i or later

•

SQLite 2 and 3

•

SQL Server 2000 or later
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•

MariaDB 5.1 or later

Supported Cloud Databases
Amazon AWS
•

Amazon Redshift

•

Amazon Aurora for MySQL

•

Amazon Aurora for PostgreSQL

•

Amazon RDS for MySQL

•

Amazon RDS for PostgreSQL

•

Amazon RDS for Oracle

•

Amazon RDS for SQL Server

•

Amazon RDS for MariaDB

Google Cloud
•

Google Cloud SQL for MySQL

•

Google Cloud SQL for PostgreSQL

•

Google Cloud SQL for SQL Server

Oracle Cloud
•

Oracle Database Cloud Service

•

Oracle MySQL Cloud Service

Microsoft Azure
•

Microsoft Azure SQL Database

•

Microsoft Azure Database for MySQL

•

Microsoft Azure Database for PostgreSQL

•

Microsoft Azure Database for MariaDB

Alibaba Cloud
•

OceanBase Community Edition

•

Alibaba Cloud ApsaraDB for RDS (MySQL)
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•

Alibaba Cloud ApsaraDB for RDS (PostgreSQL)

•

Alibaba Cloud ApsaraDB for RDS (SQL Server)

Tencent Cloud
•

Tencent Cloud TencentDB for MySQL

•

Tencent Cloud TencentDB for SQL Server

•

Tencent Cloud TencentDB for PostgreSQL

•

Tencent Cloud TencentDB for MariaDB

Huawei Cloud
•

Huawei Cloud RDS for MySQL

•

Huawei Cloud RDS for PostgreSQL

•

Huawei Cloud RDS for SQL Server

Installation
We strongly suggest that you shut down any opened applications. This will help ensure a smooth installation.
Installation for Download Version
1. Download Navicat Charts Creator Windows version.
2. Open the .exe file.
3. Click Next at the Welcome Screen.
4. Read the License Agreement. Accept it and click Next.
5. Accept the location of the program icons by clicking Next. If you wish to change the destination of the folder for
Navicat Charts Creator program click Browse.
6. Follow the remaining steps.
Installation for CD Version
1. Load the Navicat Charts Creator CD Installation disk into the CD-ROM drive.
2. Open the .exe file.
3. Click Next at the Welcome Screen.
4. Read the License Agreement. Accept it and click Next.
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5. Accept the location of the program icons by clicking Next. If you wish to change the destination of the folder for
Navicat Charts Creator program click Browse.
6. Follow the remaining steps.

Registration
When the trial period is finished, Navicat Charts Creator requires a license key or a subscription plan to continue using
the features.
Note: Perpetual License and Subscription Plan cannot be used at the same Navicat Charts Creator. Before changing
the registration method, you need to deactivate the license key or sign out your Navicat ID.

Perpetual License
If you have purchased a perpetual license, you will receive a license key for activating Navicat Charts Creator.
In the Perpetual License section, paste your license key (16 digits) and click the Activate button. Navicat Charts
Creator contacts our licensing server to activate the license key. If the activation process is successful, the license key
details are displayed.
Manual Activation
Manual activation is available when your computer does not have an internet connection. You will need another
computer with an internet connection to complete this activation process.
1. If the online activation is failed, click Manual Activation.
2. Copy the Request Code in the Copy the Request Code Here: box.
3. Open web browser on a computer with an internet connection and then go to
https://customer.navicat.com/manual_activate.php.
4. Paste/Enter the Request Code into the left box.
5. Click Get Activation Code.
6. Copy the generated Activation Code in the right box.
7. Go back to the computer where you are activating Navicat Charts Creator.
8. Paste the Activation Code into the Paste the Activation Code Here: box.
9. Click Activate.

Subscription Plan
If you have subscribed a plan, you can sign in your Navicat ID to use Navicat Charts Creator during the subscription
term.
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Note: Navicat ID is the Email address that you used to subscribe the plan.
In the Subscription section, provide your Navicat ID and Password. After signed in, the subscription plan details are
displayed.
Navicat Charts Creator contacts our licensing server once per hour to auto reload the plan by default. If you have
updated your plan in the portal site, you can use the Reload Plan button to force reloading the new plan.
Note: Each Navicat ID can connect to only one Navicat Charts Creator. If you sign in your Navicat ID in another Navicat
Charts Creator, you will be signed out from the current Navicat Charts Creator.

Migration / Upgrade
Migrate Navicat Charts Creator to a new computer
1. In Navicat Charts Creator, choose Help -> Registration.
2. [Perpetual License] Click Deactivate to online deactivate the license key.
3. [Subscription Plan] Click Sign Out to sign out your Navicat ID.
4. Uninstall Navicat Charts Creator from the existing computer.
5. Re-install Navicat Charts Creator in the new computer.
Upgrade Navicat Charts Creator
If you want to upgrade an installed copy of Navicat Charts Creator to the latest release, please choose Help -> Check
For Updates to start the Updater. It will automatically check your installed version. If there is a new version, simply
follow the steps in the Updater to upgrade your Navicat Charts Creator. It will replace your previous Navicat Charts
Creator and your current settings will remain unchanged.
Or, you can submit your registered email address on the Customer Center to download the latest version installer.

End-User License Agreement
Note: For the License Agreement of Navicat Cloud service, please click here.
IMPORTANT: THIS SOFTWARE END USER LICENSE AGREEMENT ("EULA") IS A LEGAL AGREEMENT
BETWEEN YOU (EITHER AN INDIVIDUAL OR, IF PURCHASED OR OTHERWISE ACQUIRED BY OR FOR AN
ENTITY, AN ENTITY) AND PREMIUMSOFT CYBERTECH LTD..READ IT CAREFULLY BEFORE COMPLETING THE
INSTALLATION PROCESS AND USING THE SOFTWARE. IT PROVIDES A LICENSE TO USE THE SOFTWARE
AND CONTAINS WARRANTY INFORMATION AND LIABILITY DISCLAIMERS. BY INSTALLING AND USING THE
SOFTWARE, YOU ARE CONFIRMING YOUR ACCEPTANCE OF THE SOFTWARE AND AGREEING TO BECOME
BOUND BY THE TERMS OF THIS AGREEMENT. IF YOU DO NOT AGREE TO BE BOUND BY THESE TERMS,
THEN DO NOT INSTALL THE SOFTWARE AND RETURN THE SOFTWARE TO YOUR PLACE OF PURCHASE.
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THIS EULA SHALL APPLY ONLY TO THE SOFTWARE SUPPLIED BY PREMIUMSOFT CYBERTECH LTD.
HEREWITH REGARDLESS OF WHETHER OTHER SOFTWARE IS REFERRED TO OR DESCRIBED HEREIN.
1. Definitions
a. "Non-commercial Version" means a version of the Software, so identified, for use by i) the individual
who is a natural person and not a corporation, company, partnership or association or other entity or
organization (ii) the individual who is a student, faculty or staff member at an educational institution,
and (iii) staff of a non-profit organization or charity organization only. For purposes of this definition,
"educational institution" means a public or private school, college, university and other post secondary
educational establishment. A non-profit organization is an organization whose primary objective is to
support an issue or matter of private interest or public concern for non-commercial purposes.
b. "Not For Resale (NFR) Version" means a version, so identified, of the Software to be used to review
and evaluate the Software, only.
c.

"PremiumSoft" means PREMIUMSOFT CYBERTECH LTD. and its licensors, if any.

d. "Software" means only the PremiumSoft software program(s) and third party software programs, in
each case, supplied by PremiumSoft herewith, and corresponding documentation, associated media,
printed materials, and online or electronic documentation.
e. "Unregistered version", "Trial version" or "Demo version" means an unregistered copy of the
SOFTWARE ("UNREGISTERED SOFTWARE") which may be used by the USER for evaluation
purposes for a period of fourteen (14) days following the initial installation of the UNREGISTERED
SOFTWARE. At the end of the trial period ("TRIAL PERIOD"), the USER must either register the
SOFTWARE or remove it from his system. The UNREGISTERED SOFTWARE may be freely copied
and distributed to other users for their evaluation.
f.

"Navicat Essentials" means a version of the Software, so identified, to be used for commercial
purpose.

2. License Grants
The licenses granted in this Section 2 are subject to the terms and conditions set forth in this EULA:
a. Subject to Section 2(b), you may install and use the Software on a single computer; OR install and
store the Software on a storage device, such as a network server, used only to install the Software on
your other computers over an internal network, provided you have a license for each separate
computer on which the Software is installed and run. Except as otherwise provided in Section 2(b), a
license for the Software may not be shared, installed or used concurrently on different computers.
b. In addition to the single copy of the Software permitted in Section 2(a), the primary user of the
computer on which the Software is installed may make a second copy of the Software and install it on
either a portable computer or a computer located at his or her home for his or her exclusive use,
provided that:
9

A. the second copy of the Software on the portable or home computer (i) is not used at the same
time as the copy of the Software on the primary computer and (ii) is used by the primary user
solely as allowed for such version or edition (such as for educational use only),
B. the second copy of the Software is not installed or used after the time such user is no longer
the primary user of the primary computer on which the Software is installed.
c.

In the event the Software is distributed along with other PremiumSoft software products as part of a
suite of products (collectively, the "Studio"), the license of the Studio is licensed as a single product
and none of the products in the Studio, including the Software, may be separated for installation or use
on more than one computer.

d. You may make one copy of the Software in machine-readable form solely for backup purposes. You
must reproduce on any such copy all copyright notices and any other proprietary legends on the
original copy of the Software. You may not sell or transfer any copy of the Software made for backup
purposes.
e. You agree that PremiumSoft may audit your use of the Software for compliance with these terms at
any time, upon reasonable notice. In the event that such audit reveals any use of the Software by you
other than in full compliance with the terms of this Agreement, you shall reimburse PremiumSoft for all
reasonable expenses related to such audit in addition to any other liabilities you may incur as a result
of such non-compliance.
f.

Your license rights under this EULA are non-exclusive.

3. License Restrictions
a. Other than as set forth in Section 2, you may not make or distribute copies of the Software, or
electronically transfer the Software from one computer to another or over a network.
b. You may not alter, merge, modify, adapt or translate the Software, or decompile, reverse engineer,
disassemble, or otherwise reduce the Software to a human-perceivable form.
c.

Unless otherwise provided herein, you may not rent, lease, or sublicense the Software.

d. Other than with respect to a Trial / Demo Version, Non-commercial Lite Version or a Not For Resale
Version of the Software, you may permanently transfer all of your rights under this EULA only as part
of a sale or transfer, provided you retain no copies, you transfer all of the Software (including all
component parts, the media and printed materials, any upgrades, this EULA, the serial numbers, and,
if applicable, all other software products provided together with the Software), and the recipient agrees
to the terms of this EULA. If the Software is an upgrade, any transfer must include all prior versions of
the Software from which you are upgrading. If the copy of the Software is licensed as part of the whole
Studio (as defined above), the Software shall be transferred only with and as part of the sale or transfer
of the whole Studio, and not separately. You may retain no copies of the Software. You may not sell or
transfer any Trial / Demo Version, Non-commercial Lite Version or Not For Resale Version of the
Software.
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e. Unless otherwise provided herein, you may not modify the Software or create derivative works based
upon the Software.
f.

Non-commercial Versions of the Software may not be used for, or distributed to any party for, any
commercial purpose.

g. Unless otherwise provided herein, you shall not
A. in the aggregate, install or use more than one copy of the Trial / Demo Version and
Non-commercial Lite Version of the Software,
B. download the Trial / Demo Version and Non-commercial Lite Version of the Software under
more than one username,
C. alter the contents of a hard drive or computer system to enable the use of the Trial / Demo
Version of the Software for an aggregate period in excess of the trial period for one license to
such Trial / Demo Version,
D. disclose the results of software performance benchmarks obtained using the Trial / Demo
Version or Non-commercial Lite Version to any third party without PremiumSoft prior written
consent, or
E. use the Trial / Demo Version of the Software for a purpose other than the sole purpose of
determining whether to purchase a license to a commercial or education version of the
software; provided, however, notwithstanding the foregoing, you are strictly prohibited from
installing or using the Trial / Demo Version or Non-commercial Lite Version of the Software for
any commercial training purpose.
h. You may only use the Not for Resale Version of the Software to review and evaluate the Software.
i.

You may receive the Software in more than one medium but you shall only install or use one medium.
Regardless of the number of media you receive, you may use only the medium that is appropriate for
the server or computer on which the Software is to be installed.

j.

You may receive the Software in more than one platform but you shall only install or use one platform.

k.

You shall not use the Software to develop any application having the same primary function as the
Software.

l.

In the event that you fail to comply with this EULA, PremiumSoft may terminate the license and you
must destroy all copies of the Software (with all other rights of both parties and all other provisions of
this EULA surviving any such termination).

m. This program may include Oracle Instant Client (OCI). You agree that you shall
1. not use of the Oracle Instant Client to the business operations;
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2. not assign, give, or transfer the Oracle Instant Client or an interest in them to another individual
or entity;
a. make the Programs available in any manner to any third party for use in the third
party's business operations; and
b. title to the Programs from passing to the end user or any other party;
3. not reverse engineer, disassemble or decompilation the Oracle Instant Client and duplicate the
Programs except for a sufficient number of copies of each Program for your licensed use and
one copy of each Program media;
4. discontinue use and destroy or return to all copies of the Oracle Instant Client and
documentation after termination of the Agreement;
5. not pubish any results of benchmark tests run on the Programs;
6. comply fully with all relevant export laws and regulations of the United States and other
applicable export and import laws to assure that neither the Oracle Instant Client, nor any
direct product thereof, are exported, directly or indirectly, in violation of applicable laws;
7. allow PremiumSoft to audit your use of the Oracle Instant Client;
4. Upgrades
If this copy of the Software is an upgrade from an earlier version of the Software, it is provided to you on a license
exchange basis. You agree by your installation and use of such copy of the Software to voluntarily terminate your
earlier EULA and that you will not continue to use the earlier version of the Software or transfer it to another person
or entity unless such transfer is pursuant to Section 3.
5. Ownership
The foregoing license gives you limited license to use the Software. PremiumSoft and its suppliers retain all rights,
title and interest, including all copyright and intellectual property rights, in and to, the Software (as an independent
work and as an underlying work serving as a basis for any application you may develop), and all copies thereof. All
rights not specifically granted in this EULA, including Federal and International Copyrights, are reserved by
PremiumSoft and its suppliers.
6. LIMITED WARRANTY AND DISCLAIMER
a. Except with respect to Trial / Demo Version, Non-commercial Lite Version and Not For Resale Version
of the Software, PremiumSoft warrants that, for a period of thirty (30) days from the date of delivery (as
evidenced by a copy of your receipt): the physical media on which the Software is furnished will be free
from defects in materials and workmanship under normal use. The Software is provided "as is".
PremiumSoft makes no warranties, express or implied, arising from course of dealing or usage of trade,
or statutory, as to any matter whatsoever.
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b. PremiumSoft provides no remedies or warranties, whether express or implied, for Trial / Demo version,
Non-commercial Lite version and the Not for Resale version of the Software. Trial / Demo version,
Non-commercial Lite version and the Not for Resale version of the Software are provided "as is".
c.

Except as set Forth in the foregoing limited warranty with respect to software other than Trial/ Demo
version, Non-commercial Lite version and Not for Resale version, PremiumSoft and its suppliers
disclaim all other warranties and representations, whether express, implied, or otherwise, including the
warranties of merchantability or fitness for a particular purpose. Also, there is no warranty of
non-infringement and title or quiet enjoyment. PremiumSoft does not warrant that the Software is
error-free or will operate without interruption. The Software is not designed, intended or licensed for
use in hazardous environments requiring fail-safe controls, including without limitation, the design,
construction, maintenance or operation of nuclear facilities, aircraft navigation or communication
systems, air traffic control, and life support or weapons systems. PremiumSoft specifically disclaims
any express or implied warranty of fitness for such purposes.

d. If applicable law requires any warranties with respect to the Software, all such warranties are limited in
duration to thirty (30) days from the date of delivery.
e. No oral or written information or advice given by PremiumSoft, its dealers, distributors, agents or
employees shall create a warranty or in any way increase the scope of ANY warranty PROVIDED
HEREIN.
7. LIMITATION OF LIABILITY
(a) Neither PremiumSoft nor its suppliers shall be liable to you or any third party for any indirect, special, incidental,
punitive or consequential damages (including, but not limited to, damages for the inability to use equipment or
access data, loss of business, loss of profits, business interruption or the like), arising out of the use of, or inability
to use, the Software and based on any theory of liability including breach of contract, breach of warranty,
tort (including negligence), product liability or otherwise, even if PremiumSoft or its representatives have been
advised of the possibility of such damages.
8. Third Party Software
The Software may contain third party software which requires notices and/or additional terms and conditions. By
accepting this EULA, you are also accepting the additional terms and conditions of the third party software.
9. General
No PremiumSoft dealer, agent or employee is authorized to make any amendment to this EULA.
This EULA contains the complete agreement between the parties with respect to the subject matter hereof, and
supersedes all prior or contemporaneous agreements or understandings, whether oral or written. You agree that
any varying or additional terms contained in any purchase order or other written notification or document issued by
you in relation to the Software licensed hereunder shall be of no effect. The failure or delay of PremiumSoft to
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exercise any of its rights under this EULA or upon any breach of this EULA shall not be deemed a waiver of those
rights or of the breach.
If any provision of this EULA shall be held by a court of competent jurisdiction to be contrary to law, that provision
will be enforced to the maximum extent permissible, and the remaining provisions of this EULA will remain in full
force and effect.
10. Basis of Bargain
The Limited Warranty and Disclaimer and Limited Liability set forth above are fundamental elements of the basis of
the agreement between PremiumSoft and you. PremiumSoft would not be able to provide the Software on an
economic basis without such limitations. Such Limited Warranty and Disclaimer and Limited Liability inure to the
benefit of PremiumSoft's licensors.
11. Term
By downloading and/or installing this SOFTWARE, the Licensor agrees to the terms of this EULA.
This license is effective until terminated. Licensor has the right to terminate your License immediately if you fail to
comply with any term of this License.
"as is". Licensor makes no warranties, express or implied, arising from course of dealing or usage of trade, or
statutory, as to any matter whatsoever. In particular, any and all warranties or merchantability, fitness for a
particular purpose or non-infringement of third party rights are expressly excluded.
12. Governing Law
This License will be governed by the laws in force in Hong Kong. You hereby consent to the non-exclusive
jurisdiction and venue sitting in Hong Kong to resolve any disputes arising under this EULA.
Should you have any questions concerning the validity of this License, please contact: licensing@navicat.com. If
you desire to contact the Licensor for any other reason, please contact support@navicat.com.
PremiumSoft and other trademarks contained in the Software are trademarks or registered trademarks of
PremiumSoft CyberTech Ltd. in the United States and/or other countries. Third party trademarks, trade names,
product names and logos may be the trademarks or registered trademarks of their respective owners. You may not
remove or alter any trademark, trade names, product names, logo, copyright or other proprietary notices, legends,
symbols or labels in the Software. This EULA does not authorize you to use PremiumSoft or its licensors names or
any of their respective trademarks.
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Chapter 2 - User Interface
Main Window

Navigation Pane
The Navigation pane allows you to create new workspaces, open local workspace files, recently opened workspace files,
or workspace files in Navicat Cloud / On-Prem Server. If the Navigation pane is hidden, choose View -> Show
Navigation Pane from the menu bar.
Content Pane
The Content pane contains the workspaces that are in the selected section of the Navigation pane. Use the

Detail or

Icon buttons to change the view.
Information Pane
The

General tab shows the general information of the workspace or the selected item.

The

Project tab shows the project members and the project activities done by the members. Click + to add

members to the project.
If the Information pane is hidden, choose View -> Show Information Pane from the menu bar.
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Chapter 3 - Collaboration
About Collaboration
Navicat Charts Creator allows you to synchronize connections, workspaces and virtual groups from Navicat Charts
Creator, other Navicat family members, different machines and different platforms. You can use Navicat Cloud to host
the files. Or, if you have installed our another product, Navicat On-Prem Server, in your environment, you can hosts
everything in-house.
Our collaboration feature allows you to give your teammates access to your projects when they log into their accounts.
That way, you and your teammates can work on the same project without revealing your username and password. You
can even choose to restrict the type of access your teammates have to your project.

Manage Cloud
Navicat Cloud
Navicat Cloud is a cloud service provided by PremiumSoft for synchronizing connections, queries, snippets, models,
workspaces and virtual groups.
Navicat Cloud could not connect and access your databases. By which it means, it could only store your connection
settings, queries, snippets, models, workspaces, and virtual groups; your database passwords and data (e.g. tables,
views, etc) will not be stored to Navicat Cloud.
Note: You can only sign in to one Navicat Cloud account in the software. PremiumSoft will keep all synchronized files
strictly confidential, and all employees are prohibited from viewing/accessing content of files you may store in your
Navicat Cloud account.

Create Navicat Cloud Account
1. In the menu bar, choose File -> Manage Cloud.
2. In the Manage Cloud window, select Navicat Cloud.
3. Click Create Navicat ID.
4. Enter the required information and click Sign Up. A verification email will send to your email address.
5. Click the link in the email to verify the new account.
Hint: You can sign in with the same Navicat ID you use for the Navicat Customer Center.

Sign In Navicat Cloud
1. In the menu bar, choose File -> Manage Cloud.
2. In the Manage Cloud window, select Navicat Cloud.
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3. Enter your Navicat ID and Password.
4. Click Sign In.
5. If you enabled two-step verification in Navicat Cloud Portal, a code will be sent to your phone via your mobile
app. Enter the received code to sign in.

Sign Out Navicat Cloud
1. Close all workspaces in Navicat Cloud.
2. At the top right, click your avatar.
3. In the Manage Cloud window, select Navicat Cloud.
4. Click Sign Out.

View Usage
1. At the top right, click your avatar.
2. In the Manage Cloud window, select Navicat Cloud.
3. Your usage and current plan will be shown.

Change Your Picture
1. At the top right, click your avatar.
2. In the Manage Cloud window, select Navicat Cloud.
3. Click your avatar.
4. Choose an image file.

Manage Your Account
You can change your password, enable Two-Step Verification, upgrade Cloud Plan, etc in Navicat Cloud Portal.
1. At the top right, click your avatar.
2. In the Manage Cloud window, select Navicat Cloud.
3. Click Manage Account.
4. A web browser will automatically open up to Navicat Cloud Portal.
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On-Prem Server
Navicat On-Prem Server is an on-premise solution that provides you with the option to host a cloud environment for
storing Navicat objects (connection settings, queries, snippets, models, workspaces, and virtual groups) internally at
your location.
Before you can add an On-Prem Server, you must first set up Navicat On-Prem Server in your environment.
Note: You can add multiple On-Prem Server in the software.

Add New On-Prem Server
1. In the menu bar, choose File -> Manage Cloud.
2. In the Manage Cloud window, click + New On-Prem Server -> New On-Prem Server.
3. Enter your On-Prem Server login information.
Option

Description

Host

The host name or IP address of your On-Prem Server.

Port

The port number of your On-Prem Server.

Verify Server Certificate

Enable this option to verify the server certificates.

Enable Push

Navicat Charts Creator receives a silent push notification whenever its

Synchronization

files stored in your On-Prem Server changes.

4. Click OK.

Add New On-Prem Server with URI
1. In the menu bar, choose File -> Manage Cloud.
2. In the Manage Cloud window, click + New On-Prem Server -> New On-Prem Server with URI.
3. Paste your On-Prem Server URI.
4. Click OK.
Note: The URI can be copied from your On-Prem Server portal site.

Sign In On-Prem Server
1. In the menu bar, choose File -> Manage Cloud.
2. In the Manage Cloud window, select the On-Prem Server.
3. Enter your Username and Password.
4. Click Sign In.
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5. If you enabled two-step verification, a code will be sent to you via the verification method you have selected.
Enter the received code to sign in.

Sign Out On-Prem Server
1. Close all workspaces in your On-Prem Server.
2. At the top right, click your avatar.
3. In the Manage Cloud window, select the On-Prem Server.
4. Click Sign Out.

Edit On-Prem Server
1. Close all workspaces in your On-Prem Server.
2. At the top right, click your avatar.
3. In the Manage Cloud window, select the On-Prem Server.
4. Click Sign Out.
5. Right-click your server and select Edit On-Prem Server.
6. Edit the On-Prem Server information.
7. Sign in your server.

Rename On-Prem Server
1. Close all workspaces in your On-Prem Server.
2. At the top right, click your avatar.
3. In the Manage Cloud window, select the On-Prem Server.
4. Click Sign Out.
5. Right-click your server and select Rename.
6. Enter the name to describe your On-Prem Server.
7. Sign in your server.

Remove On-Prem Server
1. Close all workspaces in your On-Prem Server.
2. At the top right, click your avatar.
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3. In the Manage Cloud window, select the On-Prem Server.
4. Click Sign Out.
5. Right-click your server and select Remove On-Prem Server.
6. Click Delete.

View Usage
1. At the top right, click your avatar.
2. In the Manage Cloud window, select the On-Prem Server.
3. Your usage will be shown.

Change Your Picture
1. At the top right, click your avatar.
2. In the Manage Cloud window, select the On-Prem Server.
3. Click your avatar.
4. Choose an image file.

Manage Your Account
You can change your password, enable Two-Step Verification, etc in your On-Prem Server web portal.
1. At the top right, click your avatar.
2. In the Manage Cloud window, select the On-Prem Server.
3. Click Manage Account.
4. A web browser will automatically open up to your On-Prem Server web portal.

Push Synchronization
Push Synchronization enables Navicat Charts Creator to receive a silent push notification whenever the files stored in
Navicat Cloud or On-Prem Server changes.

Enable Push Synchronization
1. At the top right, click your avatar.
2. In the Manage Cloud window, right-click Navicat Cloud or your On-Prem Server.
3. Turn on Enable Push Synchronization.
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Disable Push Synchronization
1. At the top right, click your avatar.
2. In the Manage Cloud window, right-click Navicat Cloud or your On-Prem Server.
3. Turn off Enable Push Synchronization.

Cache and Local Copies
When you logged into Navicat Cloud or your On-Prem Server, Navicat Charts Creator saves the cloud object files and
some information in the local computer. The cache and local copies use to make sure your changes are saved in the
cloud.

Clear Cache and Local Copies
1. At the top right, click your avatar.
2. In the Manage Cloud window, select Navicat Cloud or your On-Prem Server.
3. Click Sign Out.
4. Right-click Navicat Cloud or your On-Prem Server and select Clear Cache and Local Copies.
5. Click Clear.

Open Containing Folder
1. In the main window, select Navicat Cloud or your On-Prem Server.
2. Open your project.
3. Right-click anywhere in the project and select Open Containing Folder.

Projects
Work With Projects
A project is a way to structure and organize Navicat objects. You can put related objects in one project, and then share
the project with other accounts for collaboration if necessary.

Create New Projects
1. In the main window, select Navicat Cloud or your On-Prem Server.
2. Click + New Project.
3. Enter the name of the new project.
4. Click OK.
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Manage Existing Projects
To rename a project
1. In the main window, right-click the project and select Rename.
2. Enter a new project name.
Note: Only the project owner and the members with the Can Manage & Edit right can rename the project.
To delete a project
1. In the main window, right-click the project and select Delete Project.
2. Click Delete.
Note: Only the project owner can delete the project.
Note: Before you delete the project, you must remove all objects in the project.
To quit a project
1. In the main window, right-click the project and select Quit Project.
2. Click Quit.

Manage Members
Add Members
1. In the main window, right-click the project and select Manage Members.
2. Click Add Members.
3. [Navicat Cloud] Enter the member's Navicat ID and press ENTER.
4. [On-Prem Server] Check the boxes of the users that you want to add.
5. Select the member right.
6. Click Add.
Member Rights

Privileges

Can Manage & Edit

Read Objects, Write Objects, Manage Members and Rename
Projects

Can Edit

Read Objects and Write Objects

Can View

Read Objects

Manage Existing Members
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To edit the right of a member
1. In the main window, right-click the project and select Manage Members.
2. Use the drop-down list next to the member to change the right.
3. Click Apply.
To remove a member from a project
1. In the main window, right-click the project and select Manage Members.
2. Click the X icon next to the member.
3. Click Apply.

Connections
You can manage the connections that are synchronized to Navicat Cloud or your On-Prem Server. In the menu bar,
choose Tools -> Manage Cloud Connections.

Create New Connections
1. In the Manage Cloud Connections window, select a project.
2. Click New and select New Connection, and then select the server type.
3. Enter the server login information in the New Connection window.

Manage Existing Connections
To edit a connection
1. In the Manage Cloud Connections window, right-click a connection and select Edit Connection.
2. Change the connection settings.
3. Click OK.
To delete a connection
1. In the Manage Cloud Connections window, right-click a connection and select Delete Connection.
2. Click Delete in the confirm dialog.

Virtual Groups
Virtual Group aims to provide a platform for logical grouping objects by categories, so that all objects are effectively
preserved. It can be applied on connections and workspaces in Navicat Cloud / On-Prem Server.
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Connections
Create a new group
1. In the menu bar, choose Tools -> Manage Cloud Connections.
2. In the Manage Cloud Connections window, right-click a project and select New Group.
3. Enter a name for the new group.
Move a connection to a group
1. In the Manage Cloud Connections window, right-click a connection and select Manage Group -> Move To.
2. Select an existing group.
Move a connection to the top-level
1. In the Manage Cloud Connections window, right-click a connection and select Manage Group -> Exclude
From Group.
Hint: You can also use the drag and drop method to move objects.

Workspaces
Create a new group
1. In the main window, select Navicat Cloud or your On-Prem Server.
2. Open a project.
3. Right-click anywhere in the project and select New Group.
4. Enter a name for the new group.
Move a workspace file to a group
1. In the main window, right-click a workspace and select Manage Group -> Move To.
2. Select an existing group.
Move a workspace file to the top-level
1. In the main window, right-click a workspace and select Manage Group -> Exclude From Group.
Hint: You can also use the drag and drop method to move objects.
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Chapter 4 - Workspace
About Workspace
A workspace is the place that comprises dashboards, charts and data sources. You can create multiple dashboards,
charts and data sources in a workspace.

Workspace Toolbar
The Workspace Toolbar provides controls that you can use to create data sources, charts and dashboards.
Tab Bar
The Tab Bar allows you to switch among the opened items.
Content Pane
The Content pane shows all items in the workspace. To change the view, click the

Detail or

Icon button at the

bottom of the window.
Detail View displays additional information about each item. You can sort items in Detail View, click the column header
by which you want to sort the items.
Icon View displays your items as a grid of thumbnail images. You can filter the items by clicking a category (All, Data
Source, Chart, Dashboard) in this view.
Properties Pane
The

General tab shows the general information of the workspace or the selected item.

The

Using tab shows the items that the selected item depends on.
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The

Used By tab shows the items that depend on the selected item.

If the Properties pane is hidden, choose View -> Show Properties from the menu bar.

Create Workspace
Local Workspace File
The essential steps to create a workspace are:
1. In the main window, click

New Workspace.

2. Create data sources, charts and dashboards.
3. Choose File -> Save.
4. Enter the file name and choose the save path.
5. Click Save.

Cloud Workspace File
If you have logged into Navicat Cloud / On-Prem Server, you can store the workspace in a project.
The essential steps to create a workspace are:
1. In the main window, click

New Workspace.

2. Create data sources, charts and dashboards.
3. Choose File -> Save to Cloud.
4. Enter the workspace name and choose the project.
5. Click Save.
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Chapter 5 - Data Source
About Data Source
Data sources reference tables in your connections or data in files/ODBC sources, and can select data from tables on
different server types. The fields in the dataset can be used to construct a chart. When building a chart, you will need to
specify the data source that the chart uses.

Connections Pane
The Connections pane is the basic way to navigate with connections, databases, tables, queries.
Data Source Toolbar
The Data Source Toolbar provides controls that you can use to manipulate the data.
Design Pane
The Design pane allows you to build the data source visually.
Navicat Charts Creator provides two modes for connecting your data: Live and Achieve.
Live mode retrieves data from your servers whenever the data source is being used / loaded. It offers the convenience
of real-time updates, with any changes in the underlying data reflected.
Archive mode retrieves data from your servers during the data source creation, and stored the retrieved data in the
workspace for later use by building charts.
Preview Pane
The Preview pane displays the data of the data source.
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Properties Pane
The

Properties tab shows the general information of the data source. You can add a remark to the data source.

The

Used By tab shows the charts that depend on the data source.

If the Properties pane is hidden, choose View -> Show Properties from the menu bar.

Create Data Source
The essential steps to create a data source are:
1. In the Workspace window, click

New Data Source.

2. Enter the name of the data source and select the desired connections, files or existing data sources.
Option

Description

Database

Create data source using existing connections in Navicat Cloud or
On-Prem Server, or create a new connection in the workspace. For
more information about connection settings, see Connect to
Database Server.

File/ODBC

Import data to the workspace, or link the data source to the data in a
supported external file or ODBC source. For more information about
import steps, see Import Data from File/ODBC.

Connections in Existing

Choose the connections used in other existing data sources in the

Data Sources

workspace.

3. Click OK.
4. A tab will open for you to edit the data source.
5. If you want to add more connections, click + and follow the steps.
6. Drag and drop tables from the Connections pane to the Design pane. You can view the table data by clicking
.
7. Drag and drop a node to another to create the join.
8. Configure the join type and join fields if necessary.
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Hint: After creating the join, you can change the join settings at any time by clicking the join icon on the
connector.
9. Choose Live mode or Archive mode.
10. Click Apply and Refresh Data to view the data.

Add Query to Database Connection
For database connections, you can save query results to create a new dataset.
To create a new query
1. On the Connections pane, double-click

New Data Source Query.

2. Enter the name of the query and write the statement in SQL Editor. You can also use Query Builder to build the
query visually.

Database Connection
Connect to Database Server
You can create a connection to connect your server: MySQL, MariaDB, PostgreSQL, Oracle, SQLite, SQL Server.
Note: The tabs in the connection properties window depend on the database type you are chosen.
•

General Settings

•

Advanced Settings

•

Databases / Attached Databases Settings

•

SSL Settings

•

SSH Settings
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•

HTTP Settings

•

Compatibility Settings

General Settings
To successfully establish a new connection to local/remote server - no matter via SSL, SSH or HTTP, set the database
login information in the General tab. If your Internet Service Provider (ISP) does not provide direct access to its server,
Secure Tunneling Protocol (SSH) / HTTP is another solution.
Note: The following options depend on the connection server type and sort in ascending order.
Add To
After you logged in Navicat Cloud or On-Prem Server, you can choose to save the connection to a project.
Authentication
SQL Server

Use login records to validate the connection. Users must provide their

Authentication

server login: User Name and Password.

Windows Authentication

When a user connects through a Windows user account, SQL Server
validates the account name and password using the Windows principal
token in the operating system.

Connection Name
Enter a friendly name to best describe your connection.
Connection Type
Basic

In Basic mode, it connects to Oracle through the Oracle Call Interface
(OCI). Enter the Host and Port. Set the Service Name/SID which the user
connects when making connection. Select the corresponding radio button.

TNS

In TNS mode, it connects to Oracle server using an alias entry from a
tnsnames.ora file through the Oracle Call Interface (OCI). User needs to
provide the Net Service Name.

OCI is an application programming interface that allows an application developer to use a third-generation language's
native procedure or function calls to access the Oracle database server and control all phases of SQL statement
execution. OCI is a library of standard database access and retrieval functions in the form of a dynamic-link library. See
also: OCI options
Database File
Specify the initial database file. If the HTTP Tunnel is enabled, you need to enter an absolute file path of the database
file in your web server.
Endpoint
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The Endpoint for connecting to the Amazon Web Services instance.
Host
A host name where the database is situated or the IP address of the server.
Initial Database
Set the initial database which user connects when making connection.
Password
Password for connecting to the database server.
Port
A TCP/IP port for connecting to the database server.
Type
Existing Database File

Connect to an existing database in the Database File.

New SQLite 3

Create a new SQLite 3 database in the Database File.

New SQLite 2

Create a new SQLite 2 database in the Database File.

User Name
User name for connecting to the database server.

Advanced Settings
Note: The following options depend on the connection server type and sort in ascending order.
Client Character Set
Choose the session client character set used in Navicat Charts Creator.
Client Driver Version
Choose the client driver used to connect the server. If the default driver does not work, you can change this setting to
Legacy.
Compatibility
Enable the Compatibility tab for setting the compatibility mode for MySQL connection.
Encoding
Choose a codepage for converting data to display in Navicat Charts Creator UI.
Encrypted
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Enable this option and provide Password when connecting to an encrypted SQLite database.
Keepalive interval (sec)
Keep the connection with the server alive by pinging it. You can set the period between pings in the edit box.
Limit connection sessions
Specify the maximum number of concurrent connections that the server allows.
Native Client Driver
Choose the SQL Server Native Client used for the connection.
OS authentication
Use OS user login credentials to authenticate database users.
Role
Indicate that the database user is connecting with either the Default, SYSOPER or SYSDBA system privilege.
Use compression
Use compression protocol. It is used if both client and server support zlib compression, and the client requests
compression.
Use encryption
Use encryption for SQL Server connection.
Use named pipe, socket
Use socket file for localhost connection.

Databases / Attached Databases Settings
MySQL, Oracle, PostgreSQL, SQL Server, MariaDB
In the Databases tab, you can set which databases will be shown in the Connections pane when connecting to your
server. It is not obligatory. To start working with custom database settings, check Use custom database list. Then,
check the preferable databases in the Database column.
Add a hidden database to the list
1. Click the Add Database to List button.
2. Enter the database name.
3. Check the newly added database in the database list.
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Remove a database from the list
1. Select the database in the database list.
2. Click the Remove Database from List button.
Note: The database will be just removed from the database list box, it will still exist in the server.

SQLite
In the Attached Databases tab, you can attach SQLite database files to the connection. Click the Attach Database
button and enter the information:
Option

Description

Database File

Choose the file path of a database file.

Database Name

Enter the database name which displays in Navicat Charts Creator.

Encrypted

Check this option and provide the Password if the database file is
encrypted.

To detach a database, select it from the list and click the Detach Database button.

SSL Settings
Secure Sockets Layer (SSL) is a protocol for transmitting private documents via the Internet. To get a secure
connection, the first thing you need to do is to install OpenSSL Library and download Database Source.
Note: Available only for MySQL, PostgreSQL and MariaDB. Support from PostgreSQL 8.4 or later.

MySQL and MariaDB Connections
To provide authentication details, enable Use authentication and fill in the required information:
Client Key
The SSL key file in PEM format to use for establishing a secure connection.
Client Certificate
The SSL certificate file in PEM format to use for establishing a secure connection.
CA Certificate
The path to a file in PEM format that contains a list of trusted SSL certificate authorities.
Verify server certificate against CA
Check the server's Common Name value in the certificate that the server sends to the client.
Specified Cipher
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A list of permissible ciphers to use for SSL encryption.

PostgreSQL Connection
Choose the SSL Mode:
require

Only try an SSL connection.

verify-ca

Only try an SSL connection, and verify that the server certificate is issued
by a trusted CA.

verify-full

Only try an SSL connection, verify that the server certificate is issued by a
trusted CA and that the server hostname matches that in the certificate.

To provide authentication details, enable Use authentication and fill in the required information:
Client Key
The path of the client private key.
Client Certificate
The path of the client certificate.
Root Certificate
The path of the trusted certificate authorities.
Certificate Revocation List
The file path of the SSL certificate revocation list (CRL).

SSH Settings
Secure SHell (SSH) is a program to log in into another computer over a network, execute commands on a remote
server, and move files from one machine to another. It provides strong authentication and secure encrypted
communications between two hosts, known as SSH Port Forwarding (Tunneling), over an insecure network.
Typically, it is employed as an encrypted version of Telnet.
In a Telnet session, all communications, including username and password, are transmitted in plain-text, allowing
anyone to listen-in on your session and steal passwords and other information. Such sessions are also susceptible to
session hijacking, where a malicious user takes over your session once you have authenticated. SSH serves to prevent
such vulnerabilities and allows you to access a remote server's shell without compromising security.
Note: Available only for MySQL, Oracle, PostgreSQL, SQL Server and MariaDB.
Please make sure that the parameter - "AllowTcpForwarding" in the Linux server must be set to value "yes", otherwise,
the SSH port forwarding will be disabled. To look for the path: /etc/ssh/sshd_config. By default, the SSH port forwarding
should be enabled. Please double check the value settings.
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Even the server support SSH tunnel, however, if the port forwarding being disabled, Navicat Charts Creator cannot
connect via SSH Port 22.
Host
A host where SSH server is activated.
Note: The host name in the General tab should be set relatively to the SSH server which provided by your database
hosting company.
Port
A port where SSH server is activated, by default it is 22.
User Name
A user on SSH server machine. (It is not a user of database server.)
Authentication Method
Password

Provide the SSH server user Password.

Public Key

Private Key
It is used together with your public key. The private key should be
readable only by you.
Passphrase
A passphrase is exactly like a password, except that it applies to the keys
you are generating and not an account.

Note: HTTP Tunnel and SSH Tunnel cannot be function simultaneously. The SSH Tunnel is disabled when you select
the HTTP Tunnel and vice versa.

HTTP Settings
HTTP Tunneling is a method for connecting to a server that uses the same protocol (http://) and the same port (port 80)
as a web server does. It is used while your ISPs do not allow direct connections, but allows establishing HTTP
connections.
Note: Available only for MySQL, PostgreSQL, SQLite and MariaDB.

Uploading the Tunneling Script
To use this connection method, first thing you need to do is to upload the tunneling script to the web server where your
server is located.
Note: ntunnel_mysql.php (for both MySQL and MariaDB), ntunnel_pgsql.php or ntunnel_sqlite.php is available in
the Navicat Charts Creator installation folder.

Setting up HTTP Tunnel
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The following instruction guides you through the process of configuring a HTTP connection.
1. Select the HTTP tab and enable Use HTTP tunnel.
2. Enter URL of the tunneling script.
e.g. http://www.navicat.com/ntunnel_mysql.php
3. If your server installed a Web Application Firewall, you can check the Encode outgoing query with base64
option.
4. If the tunneling script is hosted in a password protected server or you have to access internet over a proxy
server, you can provide the required authentication details in the Authentication or Proxy tab.
Note: HTTP Tunnel and SSH Tunnel cannot be function simultaneously. The SSH Tunnel is disabled when you select
the HTTP Tunnel and vice versa.

Compatibility Settings
If your server is a variant of MySQL or has proxy middleware installed, you can enable compatibility mode and set the
corresponding settings for the connection.
Note: Available only for MySQL.
Force lower_case_table_names as
Set the value of the lower_case_table_name system variable.
Force sql_mode as
Set the value of the sql_mode system variable.
Force NDB cluster support as
Include or exclude the support for the NDBCLUSTER storage engine.
Force database listing method as
Use the SHOW DATABASES statement to retrieve the information for listing databases, or select the information from
the INFORMATION_SCHEMA database.
Force view listing method as
Use the SHOW FULL TABLES statement to retrieve the information for listing tables, or select the information from the
INFORMATION_SCHEMA database.
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File/ODBC Connection
Import Data from File/ODBC
You can import data to the workspace or link the data source to the data in a supported external file or ODBC source.
Note: The steps depend on the file type you are chosen.
•

Choose File Format

•

Choose Source File

•

Choose Delimiter

•

Choose Additional Options

•

Choose Target Table

•

Adjust Field Structures

•

Preview Data

•

Start Import

Choose File Format
Select one of the available import types for the source file.
Note: The Excel file format is according to the Microsoft Office version installed in your computer.

Choose Source File
You can import data to the workspace or link the data source to the data in a supported external file or ODBC source.
Browse the source file name. The file extension in the Import from / Link to text box changes according to the
selected import type in the first step. Select the Encoding for the source file.

Excel
Sheets will be shown in the Tables list.

Access
If there is security settings, i.e. database password and user level security in your access file, you are required to input
the necessary information. Click the Security button for more settings:
System Database File
Locate the system security file of the Access file, e.g. D:\Temp\Security.mdw.
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Database Password
Enter the password for the database if any.
Logon Name
Enter the user name set by the user level security.
Logon Password
Enter the password of that user.

ODBC
Setting up an ODBC Data Source Connection
1. In Control Panel, select Administrative Tools.
2. Select Data Sources (ODBC).
3. Click the Add button in the User DSN tab.
4. Select the appropriate ODBC driver, such as Microsoft ODBC for Oracle and click the Finish button.
5. Enter the required information.
6. Click the OK button to see your ODBC Driver in the list.
Connecting to ODBC Data Source in Navicat Charts Creator
1. Click

in Import from / Link to.

2. In the Provider tab, select the appropriate ODBC driver, such as Microsoft OLE DB Provider for ODBC
Drivers.
3. In the Connection tab, choose the data source from the Use data source name drop-down list and provide
valid username and password.
4. All available tables will be included in the Tables list if connection is success.
Hint: If you are importing from Access or ODBC, the Add Query and Modify Query buttons open the Add Query
dialog where you can construct query to import only certain rows from your source tables. In other words, import only
rows that satisfy the criteria set by you. Tables and queries will be shown in the Tables list. To delete a query, select it
and click the Delete Query button.

Choose Delimiter
TXT, CSV
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Record Delimiter
Specify the record separator of the file.
Delimited
Import the text file with delimited format.
Fixed Width
Import the text file with fixed-width format. To delimit the source column bounds, click on the desired position to create
a break line. Simply drag it to move it or double-click it to remove it.

Field Delimiter
Specify the field separator.
Text Qualifier
Specify the character that encloses text values.

XML, JSON
Tag that identifies a table row
Define a tag to identify rows.
Consider tag attributes as table field
For example:
<row age="17">
<id>1</id>
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<name>sze</name>
</row>
With this option is on, Navicat Charts Creator will recognize "age" as a field together with "id" and "name", otherwise,
only "id" and "name" will be imported as fields.
Note: Navicat Charts Creator does not support multiple level of XML file.

Choose Additional Options
The following options depend on the file format chose in the first step.
Field Name Row
Indicate which row should Navicat Charts Creator recognize as field names.
First Data Row
Indicate which row should Navicat Charts Creator start reading the actual data.
Last Data Row
Indicate which row should Navicat Charts Creator stop reading the actual data.
Note: If no field names are defined for the file, enter 1 for First Data Row and 0 for Field Name Row.
Date Order, Date Delimiter
Time Delimiter
Specify the time separator.
Date Time Order
Specify the order of date and time.
Specify the format for date and the date separator.
Decimal Symbol
Specify the decimal separator for decimal number.
Binary Data Encoding
Set binary data are imported as Base64 encoded or no encoding in the file.

Choose Target Table
You are allowed to define a new name for the target table.
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For importing multiple tables, all tables will be shown in the list.

Adjust Field Structures
Navicat Charts Creator will make assumption on the field types and length in the source table. You are allowed to
choose desired type from the drop-down list.
Hint: For importing multiple tables, select other tables from the Source Table drop-down list.

If you are importing via ODBC, the Condition Query button opens the WHERE dialog where you can specify a
WHERE clause to import only certain rows from the source. In other words, import only rows that satisfy the criteria set
by you.
Hint: Do not include the word WHERE in the clause.

Preview Data
In this step, you can preview the data for each table.
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Continue on error
Ignore errors that are encountered during the import process.

Start Import
Import Data to Workspace
Click the Import button to begin the import process. The wizard will display the import progress, execution time, and
success or failure messages.
After the import process finished, you can click the Message Log button to view the import log.

Link to Data in External File
Click the OK button.

Add Query
Query Editor
Query Editor allows you to create and edit queries.
Hint: SELECT statement will be automatically generated in Query Editor while you build in Query Builder.
Navicat Charts Creator provides a wide range advanced features, such as compelling code editing capabilities, smart
code-completion, and more.

Code Completion
Code completion feature in Navicat Charts Creator pops up a list of suggestions as you type your SQL statement in the
editor. It assists you with statement completion and the available properties of database objects, for example
databases, tables, fields, views etc with their appropriate icons and information.
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To invoke code completion, just simply press '.' for the available properties of database object currently in the scope.
When the suggestion list appears, press TAB to insert the first item. You can also select the needed item using UPPER
ARROW or DOWN ARROW and then press TAB or ENTER.

In addition, code completion can be invoked by typing a character or pressing ESC on your keyboard for SQL
keywords/database objects.

Hint: Resize the suggestion list by dragging the lower right corner.
You can enable or disable the code completion feature in Options.

Clipboard Stack
When you copy or cut some codes as usual in the editor, the copied content will also be added to Clipboard Stack.
Clipboard Stack can store up to 10 items and use the last-in-first-out logic. To paste an item from Clipboard Stack, you
can press CTRL+SHIFT+V. Press CTRL+SHIFT+V multiple times to cycle through Clipboard Stack.

Code Folding
Code folding feature enables you to collapse blocks of code such that only the first line of the block appears in SQL
Editor.
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A block of code that can be folded is indicated by an icon

to the left of the first line of the block. A vertical line

extends from the icon to the bottom of the foldable code. In contrast, a folded block of code is indicated by an icon
to left of the code block. You can fold the block by clicking

or expand it by clicking

.

Brace Highlight
Navicat Charts Creator supports to highlight the matching brace in the editor, i.e. () .
Note: The cursor must be on a brace to show the highlight.

Find and Replace
Find
The Find bar is provided for quick searching for the text in the editor. Just simply choose Edit -> Find from the menu or
press CTRL+F, and then enter a search string.

The search starts at the cursor's current position to the end of the file.
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To find the next occurrence, just simply click Next or press F3.
Replace
To open the Replace bar, simply check the Replace box. Then, enter the text you want to search and replace.
Click the Replace button to replace the first occurrence.
Click the Replace All button to replace all occurrences automatically.

There are some additional options for Find and Replace, click

:

Option

Description

Highlight All

Highlight all matches in the editor.

Incremental Search

Find matched text for the search string as each character is typed.

Match Case

Enable case sensitive search.

Regular Expression

Search regular expressions.

Whole Word

Return the objects that match the entire word of the search string.

Zoom In/Zoom Out
Navicat Charts Creator has the ability to zoom in or zoom out the SQL in the editor. Keyboard shortcuts are:
Zoom In: [CTRL+=]
Zoom Out: [CTRL+-]
Reset: [CTRL+0]

Query Builder
Navicat Charts Creator provides a useful tool called Query Builder for building queries visually. It allows you to create
and edit queries without knowledge of SQL. Even if you are familiar with SQL, the convenient and fluent graphical
interface makes it easier to create relations and visualize the query.
In the New Query window, click the Query Builder button to open the visual Query Builder.
All database objects are displayed on the left Object pane. Whereas on the middle pane, it is divided into two portions:
the upper Diagram pane, and the lower Criteria pane. When building the query, you can view the auto-generated
query on the right SQL pane.
Note: Query Builder supports SELECT statement only.
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Add Objects to Query
The first step is to decide which tables and views you need to add to the query.
To add tables and views to the query, use one of the following methods:
•

Drag them from the Object pane to the Diagram pane.

•

Double-click them on the Object pane.

You can set aliases for tables, views and subqueries by double-clicking the object title on the Diagram pane and
entering the name to use as an alias for the object name.
After you have added objects to the diagram, you can use the FROM tab to adjust the query to your needs.
•

To change the object, click the object and select an identifier.

•

To add the table alias, click <Alias>.

You can right-click an object on the Diagram pane and select Remove, or simply press DELETE key to remove the
selected object from the query.
When you remove an object, Query Builder automatically removes joins that involve that object.
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Choose Output Fields
To include fields in the query, use one of the following methods:
•

Check the left checkbox of a field name you want to add to the query on the Diagram pane.

•

To include all the fields for an object, check the * checkbox on the Diagram pane.

•

To add all fields for all objects, click

on the SELECT tab and select All fields(*).

The selected fields display on the SELECT tab. You can specify additional output field options.
•

Check the DISTINCT checkbox to force the query to return distinct results.

•

To add the field alias, click <Alias> and enter the name.

•

Click the identifier and select the Aggregate function.

•

Use the up arrow and down arrow buttons to change the order of fields.

Set Field Association
Query Builder will automatically join the tables as per the foreign key relations. If you want to associate database
objects manually, just select a field from an object and drag it to a field in another object. A connector line appears
between the two objects to visually represent the relationship and the join type.
There are two views to show the connector lines: Table Relation and Field Relation. The Field Relation view allows
you to identify matching fields in two tables, while the Table Relation view displays the join relationship between the
two tables.
All joins are initially created as INNER JOIN by default. To change the association, click or double-click the connector
line on the Diagram pane or click the JOIN keyword on the FROM tab, and then select a join type. If a join type is not
listed, you can enter a customized one in the Custom textbox.
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To remove a join, right-click the connector line and select Remove.
To modify the join condition, right-click a connector line and select Edit Join, or click the condition on the FROM tab.

The pop-up menu options of the FROM tab:
Option

Description

Insert

Add an identifier, an expression or a subquery.

Insert Bracket

Add a pair of parentheses.

Remove

Remove the identifier, expression or subquery.

Clear and Convert to

Remove the ON condition and convert it to USING clause.

USING Clause
Clear and Convert to ON

Remove the USING condition and convert it to ON clause.

Clause
Group with Bracket

Add parentheses to group the selected conditions.

Ungroup

Remove the parentheses.

Set Filter Criteria
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When retrieving data, you may want to set up a filtering expression. To filter data returned by the query, right-click a
field on the Diagram pane and select Add Field To -> WHERE and an operator.
The condition is added to the WHERE tab. You can edit the value there by clicking <Value>. If you want to add a
condition with parentheses, click

. You can change a logical operator (and/or) by clicking it. Use the up arrow and

down arrow buttons to change the order of conditions.

The pop-up menu options of the WHERE tab:
Option

Description

Toggle Negator

Reverse the meaning of the condition.

Insert

Add a condition.

Insert Custom

Add a custom condition.

Insert Bracket

Add a pair of parentheses.

Remove

Remove the condition.

Group with Bracket

Add parentheses to group the selected conditions.

Ungroup

Remove the parentheses.

Group Resulting Data
You can set the conditions for grouping query records by right-clicking a field in the Diagram pane and selecting Add
Field To -> GROUP BY.
The condition is added to the GROUP BY tab. Use the up arrow and down arrow buttons to change the order of fields.
On the HAVING tab, you can filter summarized data or grouped data. Select the identifiers, operators, aggregate or
enter expressions to include in the condition. Use the up arrow and down arrow buttons to change the order of
conditions.
The pop-up menu options of the HAVING tab:
Option

Description

Toggle Negator

Reverse the meaning of the condition.

Insert

Add a condition.

Insert Custom

Add a custom condition.

Insert Bracket

Add a pair of parentheses.

Remove

Remove the condition.
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Group with Bracket

Add parentheses to group the selected conditions.

Ungroup

Remove the parentheses.

Sort Resulting Data
You can set the way of sorting query records by right-clicking a field on the Diagram pane and selecting Add Field To
-> ORDER BY -> ASC or DESC. The condition will be added to the ORDER BY tab.

Limit Resulting Data
On the LIMIT tab, you can limit your query results to those that fall within a specified range.
Offset
Specify the number of records to be skipped. It is optional.
Limit
Specify the number of records to be displayed.
Note: Available only for MySQL, PostgreSQL, SQLite and MariaDB.

Add Expressions/Subqueries
You can add an expression or a subquery to further limit the query results. On the FROM tab, click

and select the

Expression/Subquery tab.
After entered an expression or a subquery, confirm editing by pressing the ENTER key. It will be added to the Diagram
pane indicates that the statement contains an expression or a subquery and identifies the columns it is on.

By clicking the

button, you will be switched to a subquery layer where you can build it visually in the same way as

the main query.
You can always go back to the main query by clicking (Main Query).

View Generated SQL
The SQL pane presents a read-only, formatted representation of the SQL generated by Query Builder. You can copy
the SQL that appears in the SQL pane for use in other tools. In a subquery layer, you can enable Show Current Layer
Only to show the subquery SQL.
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Zoom In/Zoom Out
Navicat Charts Creator has the ability to zoom in or zoom out the diagram. Right-click anywhere on the Diagram pane
and select Zoom -> Zoom In/Zoom Out/100%. The same effect can be achieved with keyboard shortcuts.
Zoom In: [CTRL+=]
Zoom Out: [CTRL+-]
Reset: [CTRL+0]

Modify Data Source Connections
Project Connection
To change a project connection to a workspace connection
1. On the Connections pane, right-click a connection and select Convert to Workspace Connection.
2. The connection will be moved to the "Workspace" section.
To recreate a not found connection
If the server connection in the project was removed, it will be moved to the "Not Found in Project" section. You may
need to recreate the connection in order to connect the server.
1. On the Connections pane, right-click a connection and select Recreate Connection in Project.
2. Enter the connection properties.
3. Click OK.

Workspace Connection
To edit the settings of a database connection
1. On the Connections pane, right-click a database connection and select Edit Connection.
2. Follow the steps to edit the connection.
To change the user password of a database connection
1. On the Connections pane, right-click a database connection and select Change Connection Password.
2. Enter the database user password.
3. Click OK.
To edit the settings of a file connection
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1. On the Connections pane, right-click a file connection and select Edit File Connection Settings.
2. Follow the steps to edit the connection.
To change the path of a linked file connection
1. On the Connections pane, right-click a file connection and select Change Linked File Path.
2. Follow the steps to edit the connection.
To recreate a not found connection
If Navicat Charts Creator cannot find the connection in the workspace, it will be moved to the "Not Found in Charts
Creator" section. You may need to recreate the connection in order to connect the server.
1. On the Connections pane, right-click a connection and select Recreate Connection in Workspace.
2. Enter the connection properties.
3. Click OK.

View Data
After applying and refreshing the data source, the data is displayed in the bottom data grid. You can navigate among
the records/pages using the Navigation Bar buttons.

Button

Description
First Page - move to the first page.
Previous Page - move to the previous page.
Next Page - move to the next page.
Last Page - move to the last page.
Limit Record Setting - set number of records showing on each page.

Use the Limit Record Setting
Limit records

button to enter to the edit mode.

records per page

Check this option if you want to limit the number of records showed on each page. Otherwise, all records will be
displayed in one single page. And, set the value in the edit box. The number representing the number of records
showed per page.
Note: This setting mode will take effect on current data source only. To adjust the global settings, see Options.
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Filter / Sort / Project Data
If your data source has many data or fields, you may find it easier to limit the data or fields to just the ones you want so
you can simplify the data selections.

Filter Data
Filter pane allows you to facilitate creating and applying filter criteria that you specify for the data. Click

Filter from

the toolbar to activate the Filter pane.
1. To add a new condition to the criteria, just simply click
click

. If you want to add a condition with parentheses,

.

Hint: To add parentheses to existing conditions, simply right-click on the selected conditions and select Group
with Bracket. To remove the parentheses, right-click a bracket and select Delete Bracket or Delete Bracket
and Conditions.
2. Click on the field name (next to the checkbox) and choose a field from the list.
3. Click on the operator (next to the field name) and choose a filter operator.
Filter Operator

Operator Description

=

The field is equal to 'value'.

!=

The field is not equal to 'value'.

<

The field is less than 'value'.

<=

The field is less than or equal to 'value'.

>

The field is greater than 'value'.

>=

The field is greater than or equal to 'value'.

contains

The field contains 'value'.

does not contain

The field does not contain 'value'.

begin with

The field starts with 'value'.

does not begin with

The field does not start with 'value'.

end with

The field ends with 'value'.

does not end with

The field does not end with 'value'.

is null

The field is NULL.

is not null

The field is NOT NULL.

is empty

The field is empty.

is not empty

The field is not empty.

is between

The field is between 'value1' and 'value2'.

is not between

The field is not between 'value1' and 'value2'.

is in list

The field is in the list of ('value1','value2',...).

is not in list

The field is not in the list of ('value1','value2',...).

4. Click on <?> to activate the appropriate editor and enter the criteria values. The editor used in the criteria
values box is determined by the data type assigned to the corresponding field.
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5. Click on the logical operator (next to the criteria values) to choose and or or.
6. Repeat step 1-5 to add another new condition.
7. Click Apply and Refresh Data to see the result of the filtering you made.
Hint: If you want to reverse the meaning of the conditions, right-click the selected conditions and select Toggle
Negator.

Sort Data
Navicat Charts Creator offers the ability to sort and order data. Click

Sort from the toolbar to activate the Sort

pane.
1. To add a new criteria, just simply click

.

2. Click on the field name (next to the checkbox) and choose a field from the list.
3. Click on the sorting order to choose ASC or DESC.
4. Repeat step 1-3 to add another new criteria.
5. Click Apply and Refresh Data to see the result of the sorting you made.

Project Data
You can choose which fields to include or exclude in the data source. Click

Projection from the toolbar to activate

the Projection pane.
1. Choose to Include or Exclude fields.
2. To add a new criteria, just simply click

.

3. Click on the field name (next to the checkbox) and choose a field from the list.
4. Repeat step 2-3 to add another new criteria.
5. Click Apply and Refresh Data to see the result of the projection you made.

Add Custom Fields
You can extend your data with customized fields. New fields can be created by changing the field type, concatenating
other fields, mapping to other values or sorting based on another field/customized order.

Create Custom Field
Type-Changed Field
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Field types (String, Number, Date/Time) are assigned to every field based on the actual data type of the field. If the field
was not interpreted correctly, you can adjust the field type.
1. In the bottom data grid, select a field and click

New Custom Field -> Type-Changed Field to get started.

2. In the pop-up window, enter the Target Field Name.
3. Choose the Target Field Type.
4. Set the Source Field Data Format if necessary.
5. Click OK.
Concatenated Field
You can add a new field and concatenate the data from two already existing fields.
1. In the bottom data grid, select a field and click

New Custom Field -> Concatenated Field to get started.

2. In the pop-up window, enter the Target Field Name.
3. Double-click a field on the Source Fields pane to add it to the body.
4. Edit the body and enable the Set null if all field values are null or empty option if necessary.
5. Click OK.
Mapped Field
You can create a new field populated with the results of applying a mapping rule on every value in the source field.
1. In the bottom data grid, select a field and click

New Custom Field -> Mapped Field to get started.

2. In the pop-up window, enter the Target Field Name.
3. Click Add to create a new mapping rule.
4. Enable the Compare source values with case sensitive option if necessary.
5. Choose the action for the values that are not in the mapping rules.
6. Click OK.
Custom-Sorted Field
You can create a new field to rearrange the order of the values, based on another field, or a custom order. When you
sort this new field in the chart, it will be sorted in the order you set.
1. In the bottom data grid, select a field and click

New Custom Field -> Custom-Sorted Field to get started.
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2. In the pop-up window, enter the Target Field Name.
3. [Reference Field] Choose the field which the sort order of the target field will be based on.
4. [Custom] Customize the order of the field values by moving the values to the Sorted Values list.
5. Click OK.

Edit Custom Field
1. In the bottom data grid, right-click on the customized field and select Edit XXX Field.
2. In the pop-up window, modify the field properties.
3. Click OK.

Delete Custom Field
1. In the bottom data grid, right-click on the customized field and select Remove XXX Field.
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Chapter 6 - Chart
About Chart
A chart provides visual representations of the data in your data source. It maps to a single data source, and can display
correlations between several fields in the data. You can even make the chart interactive by adding a control chart.
Note: You must add a data source before you can begin building charts.

Data Source Pane
The Data Source pane is the basic way to navigate with the data sources. If the Data Source pane is hidden, choose
View -> Show Data Source from the menu bar.
Chart Toolbar
The Chart Toolbar provides controls that you can use to manipulate the data.
Metric Pane
The Metric pane allows you to choose the chart type and add fields to the shelves from the Data Source Pane. If the
Metric pane is hidden, choose View -> Show Metric from the menu bar.
Preview Pane
The Preview pane displays the chart.
Properties Pane
The

Properties tab includes the basic layout settings, data format settings and so on. The properties vary with the

type of the chart.
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The

Using tab shows the data sources that the chart depends on.

The

Used By tab shows the dashboards that depend on the chart.

If the Properties pane is hidden, choose View -> Show Properties from the menu bar.

Build Chart
The essential steps to create a chart are:
1. In the Workspace window, click

New Chart.

2. Select the data source and enter the name of the chart.
3. A tab will open for you to edit the chart.
4. Choose the Chart Type on the middle pane.

Hint: The type of chart you will use is normally determined by the type of the data.
5. Drag fields to the corresponding shelf in the Metric pane to set axis, values, etc.
6. Select the properties on the right pane which can be further customized for your chart.
Hint: Each chart type has different properties.
7. The chart shows on the Preview pane.
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Set Field Alias
You can create aliases for fields so that their labels appear differently in the chart.
1. Click the down arrow in the field box.
2. Select Set Alias.

3. Enter the alias name.

Filter / Sort Data
Filter Source Data in Chart
You can use the Data Filter pane to filter the source data in the current chart.

Filter Display Data in Chart
You can filter the display data in 3 ways:
•

Click the down arrow in the field box and select Display Filter.

•

Use the Display Filter pane.

•

Right-click a series / data points on the chart.
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Hint: If you want to clear the filter, you need to use the Display Filter pane.

Sort Data
You can sort the data in 2 ways:
•

Click the down arrow in the field box and select Sort.

•

Use the Sort pane.

Apply Aggregate Function
Aggregate functions allow you to summarize or change the granularity of your data.
1. Click the down arrow in the field box.

2. Select Aggregate and choose an aggregate function.
Function

Description

Number
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Sum

Return the sum of all values. Null values are ignored.

Average

Return the average of all the values. Null values are ignored.

Count

Return the number of items. Null values are not counted.

Count(Distinct)

Return the number of distinct items. Null values are not counted.

Min

Return the minimum value across all records. Null values are ignored.

Max

Return the maximum value across all records. Null values are ignored.

Median

Return the median value across all records. Null values are ignored.

DateTime
Count

Return the number of items. Null values are not counted.

Count(Distinct)

Return the number of distinct items. Null values are not counted.

Year

Return the year of the date (0000-9999).

Quarter

Return the year of the date (0000-9999) and the quarter of the year
(Q1-Q4).

Month

Return the year (0000-9999) and the month (01-12) of the date.

Week

Return the year of the date (0000-9999) and the week of the year
(W01-W52, start of week is Sunday).

Day

Return the date.

Hour

Return the date and the hour of the time (00-23).

Minute

Return the date, the hour of the time (00-23) and the minute of the
time (00-59).

Second

Return the datetime.

Quarter (Extract)

Return the quarter of the year (Q1-Q4).

Month (Extract)

Return the month of the date (01-12).

Week (Extract)

Return the week of the year (W01-W52, start of week is Sunday).

Day (Extract)

Return the day of the date (01-31).

Hour (Extract)

Return the hour of the time (00-23).

Minute (Extract)

Return the minute of the time (00-59).

Second (Extract)

Return the second of the time (00-59).

Text
First

Return the value of the first record.

Last

Return the value of the last record.

Count

Return the number of items. Null values are not counted.

Count(Distinct)

Return the number of distinct items. Null values are not counted.

Add Range
You can aggregate data into ranges without the need to create any additional calculations in the data source.
1. Click the down arrow in the field box.
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2. Select Add Range.
3. Edit the range settings.
Option

Description

Range Type - Fixed
Bin Size

Either enter the size of a bin or click Calculate to let Navicat Charts
Creator calculate a value for you.

Range Type - Custom
Stop Values

Add the bin boundaries.

4. Click OK.

Set Value Operation
You can create a chart that shows a running total as values are added or subtracted.
1. Click the down arrow in the field box.

2. Select Value Operation and choose an operation.
Operation

Description

Cumulative

Sum the values cumulatively.

Subtract

Subtract the value with its previous value.

Chart Types
About Chart Types
Navicat Charts Creator provides a variety of different chart types so data can be displayed in a meaningful way.
Here is a complete list of available chart types:
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•

Vertical Bar Chart

•

Vertical Stacked Bar Chart

•

Horizontal Bar Chart

•

Horizontal Stacked Bar Chart

•

Line Chart

•

Area Chart

•

Stacked Area Chart

•

Bar and Line Chart

•

Stacked Bar and Line Chart

•

Waterfall Chart

•

Tornado Chart

•

Pie Chart

•

Donut Chart

•

Scatter Chart

•

Heatmap

•

Treemap

•

Value

•

Trend

•

KPI

•

Gauge

•

Table

•

Pivot Table

•

Control

Bar Chart
A bar chart provides high-level overviews of data trends by comparing values within a specific category.
•

Vertical Bar Chart
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•

Vertical Stacked Bar Chart

•

Horizontal Bar Chart

•

Horizontal Stacked Bar Chart

Chart Properties
Once you have selected a chart type, you can customize the chart by changing its properties:
Option

Description

General
Background Color

Set the background color of the chart area.

Show border

Display the outer chart border.

Border Color

Set the color of the outer chart border.

Show title

Display the chart's main title.

Title

Specify the title of the chart.

Title Font

Set the font style of the title.

Position

Set the position of the title.

Align

Set the vertical or horizontal alignment of the title.

Remarks

Enter remarks for the chart.

Legend
Show legend

Display the legend container.

Position

Set the position for the legend.

Align

Set the vertical or horizontal alignment of the legend.

Label Color

Set the color of the legend labels.

Data
Show Bar Labels

Display the data labels of the selected series.

Bar Label Contains

Display the data values or/and the percentages on the labels.

Bar Label Position

Set the position of the bar labels.
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Use 100% stacked

Use 100% stacked bars to show values for hierarchical data. (Each bar
height is 100%, and the colored bar segments represent the components'
relative contributions to the total bar.)

Bar Label Font

Set the font style of the bar labels.

Use custom data value

Customize the color of the labels of the data values.

color
Positive Data Value Color

Set the color of the positive value labels.

Negative Data Value

Set the color of the negative value labels.

Color
Show only top #

Only the top # data are displayed.

Style

Plot discrete or continuous data series on the chart.

Density

Choose the density of the data series.

Color

Set the color palette of the data series.

All Data Colors

Allow setting the color for each series.

Data Formats - Number
Prefix

Add prefix characters to all the numeric data on the chart.

Unit

Choose the unit to shorten the numeric data.

Suffix

Specify the suffix to label the customized unit.

Divider

Specify the divider for the customized unit.

Thousand Separator

Choose the thousands separator for numeric data.

Decimal Separator

Choose the decimal separator for numeric data.

Decimal Places

Specify decimal places for numeric data.

Negatives

Choose the format negative numbers are displayed.

Data Formats - DateTime
Date / Time

Choose the date and time format of the data.

Custom

Customize the date and time format.

X-Axis
Show X-Axis title

Display the title of X-Axis.

X-Axis Title

Specify the title of X-Axis.

Font

Set the font style of X-Axis title.

Show X-Axis title at the

Display the title at the end of X-Axis.

end of axis
Fill missing values

Use a continuous axis. The data series are positioned according to their
domain value.

X-Axis Label Rotation

Rotate X-Axis labels.

X-Axis Label Interval

Change the interval between X-Axis labels.

Show X-Axis labels

Display labels on X-Axis.

Show X-Axis

Display X-Axis line.

X-Axis Color

Set the color of X-Axis line.

Y-Axis
Show Y-Axis title

Display the title of Y-Axis.
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Y-Axis Title

Specify the title of Y-Axis.

Font

Set the font style of Y-Axis title.

Show Y-Axis title at the

Display the title at the end of Y-Axis.

end of axis
Show Y-Axis labels

Display labels on Y-Axis.

Show Y-Axis

Display Y-Axis line.

Y-Axis Color

Set the color of Y-Axis line.

Show grid line

Display the grid line of Y-Axis.

Use custom range

Set the range of the grid lines. Enter values in Start and End. The graph
drawing beyond this range will be clipped off.

Use custom interval

Change the Interval on Y-Axis.

Tick Interval

Set the interval of the tick marks in axis units.

Trend Line
Add a trend line to the chart to show visual data trends.
Remove the selected trend line.
Rename the selected trend line.
Value

Select a data series for the trend line.

Group Value

Select a group value for the trend line.

Type

Choose the type of trend line you want.

Show R²value

Display the R²value on the chart.

Forward Forecast /

Specify the number of periods to include in a forecast.

Backward Forecast
Align with other trend lines

Align the trend line with others.

Period

Specify the number of data points used to average the point value.

Smooth

Smooth the angles of the line.

Use custom color

Customize the color of the line.

Line Color

Set the color of the line.

Cap Style

Choose the cap style of the line.

Dash Style

Choose the dash style of the line.

Join Style

Choose the join style of the line.

Visible

Check this box to show the line.

Line / Area Chart
A line or area chart displays information as a series of data points connected by straight line segments.
•

Line Chart

•

Area Chart

•

Stacked Area Chart
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Chart Properties
Once you have selected a chart type, you can customize the chart by changing its properties:
Option

Description

General
Background Color

Set the background color of the chart area.

Show border

Display the outer chart border.

Border Color

Set the color of the outer chart border.

Show title

Display the chart's main title.

Title

Specify the title of the chart.

Title Font

Set the font style of the title.

Position

Set the position of the title.

Align

Set the vertical or horizontal alignment of the title.

Remarks

Enter remarks for the chart.

Legend
Show legend

Display the legend container.

Position

Set the position for the legend.

Align

Set the vertical or horizontal alignment of the legend.

Label Color

Set the color of the legend labels.

Data
Smoothed Line

Plot a smooth line through the data points.

Show Line Labels / Show

Display the data labels of the selected series.

Area Labels
Line Label Contains

Display the data values or/and the percentages on the labels.

Line Label Pattern

Select the values that will be displayed on the chart.

Show markers

Display the marker points on the line / area.

Use 100% stacked

Use 100% stacked areas to show values for hierarchical data. (The area
height is 100%, and the colored area segments represent the components'
relative contributions to the total area.)

Use custom data value

Customize the color of the labels of the data values.
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color
Positive Data Value Color

Set the color of the positive value labels.

Negative Data Value

Set the color of the negative value labels.

Color
Show only top #

Only the top # data are displayed.

Density

Choose the density of the data series.

Color

Set the color palette of the data series.

Data Formats - Number
Prefix

Add prefix characters to all the numeric data on the chart.

Unit

Choose the unit to shorten the numeric data.

Suffix

Specify the suffix to label the customized unit.

Divider

Specify the divider for the customized unit.

Thousand Separator

Choose the thousands separator for numeric data.

Decimal Separator

Choose the decimal separator for numeric data.

Decimal Places

Specify decimal places for numeric data.

Negatives

Choose the format negative numbers are displayed.

Data Formats - DateTime
Date / Time

Choose the date and time format of the data.

Custom

Customize the date and time format.

X-Axis
Show X-Axis title

Display the title of X-Axis.

X-Axis Title

Specify the title of X-Axis.

Font

Set the font style of X-Axis title.

Show X-Axis title at the

Display the title at the end of X-Axis.

end of axis
Fill missing values

Use a continuous axis. The data series are positioned according to their
domain value.

X-Axis Label Rotation

Rotate X-Axis labels.

X-Axis Label Interval

Change the interval between X-Axis labels.

Show X-Axis labels

Display labels on X-Axis.

Show X-Axis

Display X-Axis line.

X-Axis Color

Set the color of X-Axis line.

Y-Axis
Show Y-Axis title

Display the title of Y-Axis.

Y-Axis Title

Specify the title of Y-Axis.

Font

Set the font style of Y-Axis title.

Show Y-Axis title at the

Display the title at the end of Y-Axis.

end of axis
Show Y-Axis labels

Display labels on Y-Axis.

Show Y-Axis

Display Y-Axis line.

Y-Axis Color

Set the color of Y-Axis line.
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Show grid line

Display the grid line of Y-Axis.

Use custom range

Set the range of the grid lines. Enter values in Start and End. The graph
drawing beyond this range will be clipped off.

Use custom interval

Change the Interval on Y-Axis.

Tick Interval

Set the interval of the tick marks in axis units.

Trend Line
Add a trend line to the chart to show visual data trends.
Remove the selected trend line.
Rename the selected trend line.
Value

Select a data series for the trend line.

Group Value

Select a group value for the trend line.

Type

Choose the type of trend line you want.

Show R²value

Display the R²value on the chart.

Forward Forecast /

Specify the number of periods to include in a forecast.

Backward Forecast
Align with other trend lines

Align the trend line with others.

Period

Specify the number of data points used to average the point value.

Smooth

Smooth the angles of the line.

Use custom color

Customize the color of the line.

Line Color

Set the color of the line.

Cap Style

Choose the cap style of the line.

Dash Style

Choose the dash style of the line.

Join Style

Choose the join style of the line.

Visible

Check this box to show the line.

Bar and Line Chart
Mixing bar and line chart in the same visual is a good way to emphasize the difference between series while still
maintaining their relationship.
•

Bar and Line Chart

•

Stacked Bar and Line Chart
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Chart Properties
Once you have selected a chart type, you can customize the chart by changing its properties:
Option

Description

General
Background Color

Set the background color of the chart area.

Show border

Display the outer chart border.

Border Color

Set the color of the outer chart border.

Show title

Display the chart's main title.

Title

Specify the title of the chart.

Title Font

Set the font style of the title.

Position

Set the position of the title.

Align

Set the vertical or horizontal alignment of the title.

Remarks

Enter remarks for the chart.

Legend
Show legend

Display the legend container.

Position

Set the position for the legend.

Align

Set the vertical or horizontal alignment of the legend.

Label Color

Set the color of the legend labels.

Data
Smoothed Line

Plot a smooth line through the data points.

Show Labels

Display the data labels of the selected series.

Bar Label Contains

Display the data values or/and the percentages on the labels.

Bar Label Position

Set the position of the bar labels.

Bar Label Font

Set the font style of the bar labels.

Use 100% stacked bar

Use 100% stacked bars to show values for hierarchical data. (Each bar
height is 100%, and the colored bar segments represent the components'
relative contributions to the total bar.)

Line Label Contains

Display the data values or/and the percentages on the labels.
70

Line Label Pattern

Select the values that will be displayed on the chart.

Show line markers

Display the marker points on the line.

Use custom data value

Customize the color of the labels of the data values.

color
Positive Data Value Color

Set the color of the positive value labels.

Negative Data Value

Set the color of the negative value labels.

Color
Show only top #

Only the top # data are displayed.

Style

Plot discrete or continuous data series on the chart.

Density

Choose the density of the data series.

Color

Set the color palette of the data series.

All Bar Data Colors

Allow setting the color for each series.

Data Formats - Number
Prefix

Add prefix characters to all the numeric data on the chart.

Unit

Choose the unit to shorten the numeric data.

Suffix

Specify the suffix to label the customized unit.

Divider

Specify the divider for the customized unit.

Thousand Separator

Choose the thousands separator for numeric data.

Decimal Separator

Choose the decimal separator for numeric data.

Decimal Places

Specify decimal places for numeric data.

Negatives

Choose the format negative numbers are displayed.

Data Formats - DateTime
Date / Time

Choose the date and time format of the data.

Custom

Customize the date and time format.

X-Axis
Show X-Axis title

Display the title of X-Axis.

X-Axis Title

Specify the title of X-Axis.

Font

Set the font style of X-Axis title.

Show X-Axis title at the

Display the title at the end of X-Axis.

end of axis
Fill missing values

Use a continuous axis. The data series are positioned according to their
domain value.

X-Axis Label Rotation

Rotate X-Axis labels.

X-Axis Label Interval

Change the interval between X-Axis labels.

Show X-Axis labels

Display labels on X-Axis.

Show X-Axis

Display X-Axis line.

X-Axis Color

Set the color of X-Axis line.

Y-Axis / Secondary Y-Axis
Show Y-Axis title / Show

Display the title of Y-Axis.

Secondary Y-Axis title
Y-Axis Title / Secondary

Specify the title of Y-Axis.
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Y-Axis Title
Font

Set the font style of Y-Axis title.

Show Y-Axis title at the

Display the title at the end of Y-Axis.

end of axis / Show
Secondary Y-Axis title at
the end of axis
Show Y-Axis labels /

Display labels on Y-Axis.

Show Secondary Y-Axis
labels
Show Y-Axis / Show

Display Y-Axis line.

Secondary Y-Axis
Y-Axis Color / Secondary

Set the color of Y-Axis line.

Y-Axis Color
Show grid line

Display the grid line of Y-Axis.

Use custom range

Set the range of the grid lines. Enter values in Start and End. The graph
drawing beyond this range will be clipped off.

Use custom interval

Change the Interval on Y-Axis.

Tick Interval

Set the interval of the tick marks in axis units.

Trend Line
Add a trend line to the chart to show visual data trends.
Remove the selected trend line.
Rename the selected trend line.
Value

Select a data series for the trend line.

Group Value

Select a group value for the trend line.

Type

Choose the type of trend line you want.

Show R²value

Display the R²value on the chart.

Forward Forecast /

Specify the number of periods to include in a forecast.

Backward Forecast
Align with other trend lines

Align the trend line with others.

Period

Specify the number of data points used to average the point value.

Smooth

Smooth the angles of the line.

Use custom color

Customize the color of the line.

Line Color

Set the color of the line.

Cap Style

Choose the cap style of the line.

Dash Style

Choose the dash style of the line.

Join Style

Choose the join style of the line.

Visible

Check this box to show the line.

Waterfall Chart
A waterfall chart is a special type of bar chart. It is useful for understanding how the starting value is affected by a
series of changes (increase or decrease).
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Chart Properties
Once you have selected a chart type, you can customize the chart by changing its properties:
Option

Description

General
Background Color

Set the background color of the chart area.

Show border

Display the outer chart border.

Border Color

Set the color of the outer chart border.

Show title

Display the chart's main title.

Title

Specify the title of the chart.

Title Font

Set the font style of the title.

Position

Set the position of the title.

Align

Set the vertical or horizontal alignment of the title.

Remarks

Enter remarks for the chart.

Legend
Show legend

Display the legend container.

Position

Set the position for the legend.

Align

Set the vertical or horizontal alignment of the legend.

Label Color

Set the color of the legend labels.

Data
Show data values

Display the values of the data series.

Bar Label Position

Set the position of the bar labels.

Bar Label Font

Set the font style of the bar labels.

Total Bar Color

Set the color of the Total bar.

Subtotal Bar Color

Set the color of the Subtotal bar.

Total Bar Title

Specify the title of the Total bar.

Use increase and

Color the bars with Increase Color and Decrease Color.

decrease color
Increase Color

Set the color of the bar when the value increases.
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Decrease Color

Set the color of the bar when the value decreases.

Use custom data value

Customize the color of the labels of the data values.

color
Positive data value color

Set the color of the positive value labels.

Negative data value color

Set the color of the negative value labels.

Show only top #

Only the top # data are displayed.

Style

Plot discrete or continuous bars on the chart.

Density

Choose the density of the bars.

Group Value Sorting

Sort the group values (from Decrease to Increase, or from Increase to
Decrease).

Color

Set the color palette of the data series.

All Data Colors

Allow setting the color for each series.

Data Formats - Number
Prefix

Add prefix characters to all the numeric data on the chart.

Unit

Choose the unit to shorten the numeric data.

Suffix

Specify the suffix to label the customized unit.

Divider

Specify the divider for the customized unit.

Thousand Separator

Choose the thousands separator for numeric data.

Decimal Separator

Choose the decimal separator for numeric data.

Decimal Places

Specify decimal places for numeric data.

Negatives

Choose the format negative numbers are displayed.

Data Formats - DateTime
Date / Time

Choose the date and time format of the data.

Custom

Customize the date and time format.

X-Axis
Show X-Axis title

Display the title of X-Axis.

X-Axis Title

Specify the title of X-Axis.

Font

Set the font style of X-Axis title.

Show X-Axis title at the

Display the title at the end of X-Axis.

end of axis
Fill missing values

Use a continuous axis. The data series are positioned according to their
domain value.

X-Axis Label Rotation

Rotate X-Axis labels.

X-Axis Label Interval

Change the interval between X-Axis labels.

Show X-Axis labels

Display labels on X-Axis.

Show X-Axis

Display X-Axis line.

X-Axis Color

Set the color of X-Axis line.

Y-Axis
Show Y-Axis title

Display the title of Y-Axis.

Y-Axis Title

Specify the title of Y-Axis.

Font

Set the font style of Y-Axis title.
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Show Y-Axis title at the

Display the title at the end of Y-Axis.

end of axis
Show Y-Axis labels

Display labels on Y-Axis.

Show Y-Axis

Display Y-Axis line.

Y-Axis Color

Set the color of Y-Axis line.

Show grid line

Display the grid line of Y-Axis.

Use custom range

Set the range of the grid lines. Enter values in Start and End. The graph
drawing beyond this range will be clipped off.

Use custom interval

Change the Interval on Y-Axis.

Tick Interval

Set the interval of the tick marks in axis units.

Tornado Chart
A tornado chart is a special type of bar chart. It is useful for comparing data among different types of data or categories.

Chart Properties
Once you have selected a chart type, you can customize the chart by changing its properties:
Option

Description

General
Background Color

Set the background color of the chart area.

Show border

Display the outer chart border.

Border Color

Set the color of the outer chart border.

Show title

Display the chart's main title.

Title

Specify the title of the chart.

Title Font

Set the font style of the title.

Position

Set the position of the title.

Align

Set the vertical or horizontal alignment of the title.
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Remarks

Enter remarks for the chart.

Legend
Show legend

Display the legend container.

Position

Set the position for the legend.

Align

Set the vertical or horizontal alignment of the legend.

Label Color

Set the color of the legend labels.

Data
Show Bar Labels

Display the data labels of the selected series.

Bar Label Contains

Display the data values or/and the percentages on the labels.

Bar Label Position

Set the position of the bar labels.

Bar Label Font

Set the font style of the bar labels.

Use stack

Use stacked bars to show values.

Use 100% stacked

Use 100% stacked bars to show values for hierarchical data. (Each bar
height is 100%, and the colored bar segments represent the components'
relative contributions to the total bar.)

Stacked Bar Style

Determine how the stacked section is displayed.

Negative Data Bar

Set the color of the negative data bars.

Background Color
Minimum Value

Set the minimum value of the bar.

Data Label Color

Set the color of the data labels on the bars.

Use custom data value

Customize the color of the labels of the data values.

color
Positive data value color

Set the color of the positive value labels.

Negative data value color

Set the color of the negative value labels.

Show only top #

Only the top # data are displayed.

Style

Plot discrete or continuous bars on the chart.

Density

Choose the density of the bars.

Color

Set the color palette of the data series.

All Data Colors

Allow setting the color for each series.

Data Formats - Number
Prefix

Add prefix characters to all the numeric data on the chart.

Unit

Choose the unit to shorten the numeric data.

Suffix

Specify the suffix to label the customized unit.

Divider

Specify the divider for the customized unit.

Thousand Separator

Choose the thousands separator for numeric data.

Decimal Separator

Choose the decimal separator for numeric data.

Decimal Places

Specify decimal places for numeric data.

Negatives

Choose the format negative numbers are displayed.

Data Formats - DateTime
Date / Time

Choose the date and time format of the data.

Custom

Customize the date and time format.
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Y-Axis
Axis position

Set the position of Y-Axis.

Show Y-Axis title

Display the title of Y-Axis.

Y-Axis Title

Specify the title of Y-Axis.

Font

Set the font style of Y-Axis title.

Fill missing values

Use a continuous axis. The data series are positioned according to their
domain value.

Y-Axis Label Interval

Change the interval between Y-Axis labels.

Show Y-Axis labels

Display labels on Y-Axis.

Y-Axis Color

Set the color of Y-Axis line.

X-Axis
Show X-Axis title

Display the title of X-Axis.

Left X-Axis Title

Specify the title of the left X-Axis.

Right X-Axis Title

Specify the title of the right X-Axis.

Font

Set the font style of X-Axis title.

Show X-Axis title at the

Display the title at the end of X-Axis.

end of axis
Show X-Axis labels

Display labels on X-Axis.

Show X-Axis

Display X-Axis line.

X-Axis Color

Set the color of X-Axis line.

Show grid line

Display the grid line of X-Axis.

Use custom range

Set the range of the grid lines. Enter values in Start and End. The graph
drawing beyond this range will be clipped off.

Use custom interval

Change the Interval on X-Axis.

Tick Interval

Set the interval of the tick marks in axis units.

Pie / Donut Chart
A pie or donut chart displays data in a series of segments of a circle, with larger segments representing larger data
values.
•

Pie Chart

•

Donut Chart
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Chart Properties
Once you have selected a chart type, you can customize the chart by changing its properties:
Option

Description

General
Background Color

Set the background color of the chart area.

Show border

Display the outer chart border.

Border Color

Set the color of the outer chart border.

Show title

Display the chart's main title.

Title

Specify the title of the chart.

Title Font

Set the font style of the title.

Position

Set the position of the title.

Align

Set the vertical or horizontal alignment of the title.

Remarks

Enter remarks for the chart.

Legend
Show legend

Display the legend container.

Position

Set the position for the legend.

Align

Set the vertical or horizontal alignment of the legend.

Label Color

Set the color of the legend labels.

Data
Show data labels

Display data labels that clarify the data series.

Show data values

Display the values of the data series.

Show data percentages

Display the data percentages of the slices.

Show label inside slice

Position the slice labels inside the slice. Labels for smaller slices are hidden.

Show label over other

All labels are shown. Labels for smaller slices will overlap other slices.

slices
Show slice separator

Add white borders between pie / donut slices.

Data Label Color

Set the color of the data label.

Show only top #

Only the top # data are displayed.

Slice

Group the small slices to a single slice (called Others).
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Color

Set the color palette of the data series.

Data Formats - Number
Prefix

Add prefix characters to all the numeric data on the chart.

Unit

Choose the unit to shorten the numeric data.

Suffix

Specify the suffix to label the customized unit.

Divider

Specify the divider for the customized unit.

Thousand Separator

Choose the thousands separator for numeric data.

Decimal Separator

Choose the decimal separator for numeric data.

Decimal Places

Specify decimal places for numeric data.

Negatives

Choose the format negative numbers are displayed.

Data Formats - DateTime
Date / Time

Choose the date and time format of the data.

Custom

Customize the date and time format.

Group
Show group title

Display the title of the group.

Group Title

Specify the title of the group.

Group Title Font

Set the font style of the group title.

Scatter Chart
A scatter chart plots data with individual data points placed along the X and Y axes.

Chart Properties
Once you have selected a chart type, you can customize the chart by changing its properties:
Option

Description
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General
Background Color

Set the background color of the chart area.

Show border

Display the outer chart border.

Border Color

Set the color of the outer chart border.

Show title

Display the chart's main title.

Title

Specify the title of the chart.

Title Font

Set the font style of the title.

Position

Set the position of the title.

Align

Set the vertical or horizontal alignment of the title.

Remarks

Enter remarks for the chart.

Legend
Show legend

Display the legend container.

Position

Set the position for the legend.

Align

Set the vertical or horizontal alignment of the legend.

Label Color

Set the color of the legend labels.

Data
Show size values

Display the size of the bubbles.

Density

Choose the density of the data series.

Color

Set the color palette of the data series.

Data Formats - Number
Prefix

Add prefix characters to all the numeric data on the chart.

Unit

Choose the unit to shorten the numeric data.

Suffix

Specify the suffix to label the customized unit.

Divider

Specify the divider for the customized unit.

Thousand Separator

Choose the thousands separator for numeric data.

Decimal Separator

Choose the decimal separator for numeric data.

Decimal Places

Specify decimal places for numeric data.

Negatives

Choose the format negative numbers are displayed.

Data Formats - DateTime
Date / Time

Choose the date and time format of the data.

Custom

Customize the date and time format.

X-Axis
Show X-Axis title

Display the title of X-Axis.

X-Axis Title

Specify the title of X-Axis.

Font

Set the font style of X-Axis title.

Show X-Axis title at the

Display the title at the end of X-Axis.

end of axis
X-Axis Label Rotation

Rotate X-Axis labels.

X-Axis Label Interval

Change the interval between X-Axis labels.

Show X-Axis labels

Display labels on X-Axis.

Show X-Axis

Display X-Axis line.
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X-Axis Color

Set the color of X-Axis line.

Show grid line

Display the grid line of X-Axis.

Use custom range

Set the range of the grid lines. Enter values in Start and End. The graph
drawing beyond this range will be clipped off.

Use custom interval

Change the Interval on X-Axis.

Tick Interval

Set the interval of the tick marks in axis units.

Y-Axis
Show Y-Axis title

Display the title of Y-Axis.

Y-Axis Title

Specify the title of Y-Axis.

Font

Set the font style of Y-Axis title.

Show Y-Axis title at the

Display the title at the end of Y-Axis.

end of axis
Show Y-Axis labels

Display labels on Y-Axis.

Show Y-Axis

Display Y-Axis line.

Y-Axis Color

Set the color of Y-Axis line.

Show grid line

Display the grid line of Y-Axis.

Use custom range

Set the range of the grid lines. Enter values in Start and End. The graph
drawing beyond this range will be clipped off.

Use custom interval

Change the Interval on Y-Axis.

Tick Interval

Set the interval of the tick marks in axis units.

Trend Line
Add a trend line to the chart to show visual data trends.
Remove the selected trend line.
Rename the selected trend line.
Value

Select a data series for the trend line.

Group Value

Select a group value for the trend line.

Type

Choose the type of trend line you want.

Show R²value

Display the R²value on the chart.

Forward Forecast /

Specify the number of periods to include in a forecast.

Backward Forecast
Align with other trend lines

Align the trend line with others.

Period

Specify the number of data points used to average the point value.

Smooth

Smooth the angles of the line.

Use custom color

Customize the color of the line.

Line Color

Set the color of the line.

Cap Style

Choose the cap style of the line.

Dash Style

Choose the dash style of the line.

Join Style

Choose the join style of the line.

Visible

Check this box to show the line.
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Heatmap
A heatmap represents data in a tabular format as a range of color. A more intense color represents a larger aggregated
value for a particular data point.

Chart Properties
Once you have selected a chart type, you can customize the chart by changing its properties:
Option

Description

General
Background Color

Set the background color of the chart area.

Show border

Display the outer chart border.

Border Color

Set the color of the outer chart border.

Show title

Display the chart's main title.

Title

Specify the title of the chart.

Title Font

Set the font style of the title.

Position

Set the position of the title.

Align

Set the vertical or horizontal alignment of the title.

Remarks

Enter remarks for the chart.

Legend
Show legend

Display the legend container.

Position

Set the position for the legend.

Label Color

Set the color of the legend labels.

Data
Show data values

Display the values of the data series.

Data Label Color

Set the color of the data label.

Diverging

Use diverging color scale.

Use custom min/max

Customize the color of the min, center, and max values. Navicat Charts
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values

Creator calculates the cell color based on the color of these values.

Min Color

Set the color of the minimum value in the colormap.

Center Color

Set the color of the value at which to center the colormap.

Max Color

Set the color of the maximum value in the colormap.

Min Value

Specify the minimum value.

Max Value

Specify the maximum value.

Data Formats - Number
Prefix

Add prefix characters to all the numeric data on the chart.

Unit

Choose the unit to shorten the numeric data.

Suffix

Specify the suffix to label the customized unit.

Divider

Specify the divider for the customized unit.

Thousand Separator

Choose the thousands separator for numeric data.

Decimal Separator

Choose the decimal separator for numeric data.

Decimal Places

Specify decimal places for numeric data.

Negatives

Choose the format negative numbers are displayed.

Data Formats - DateTime
Date / Time

Choose the date and time format of the data.

Custom

Customize the date and time format.

Column
Show column title

Display the title of the column.

Column Title

Specify the title of the column.

Column Title Font

Set the font style of the column title.

Show column label

Display the column label.

Column Label Color

Set the color of the column label.

Row
Show row title

Display the title of the row.

Row Title

Specify the title of the row.

Row Title Font

Set the font style of the row title.

Show row label

Display the row label.

Row Label Color

Set the color of the row label.

Treemap
A treemap is an alternative way of visualizing the hierarchical structure while also displaying quantities for each
category via area size.
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Chart Properties
Once you have selected a chart type, you can customize the chart by changing its properties:
Option

Description

General
Background Color

Set the background color of the chart area.

Show border

Display the outer chart border.

Border Color

Set the color of the outer chart border.

Show title

Display the chart's main title.

Title

Specify the title of the chart.

Title Font

Set the font style of the title.

Position

Set the position of the title.

Align

Set the vertical or horizontal alignment of the title.

Remarks

Enter remarks for the chart.

Legend
Show legend

Display the legend container.

Position

Set the position for the legend.

Align

Set the vertical or horizontal alignment of the legend.

Label Color

Set the color of the legend labels.

Data
Show data point names

Display the names of the data points.

Show data values

Display the values of the data points.

Show data percentages

Display the data percentages of the data points.

Data Label Color

Set the color of the data label.
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Tile

Group the small tiles to a single tile (called Others).

Color

Set the color palette of the data points.

Data Formats - Number
Prefix

Add prefix characters to all the numeric data on the chart.

Unit

Choose the unit to shorten the numeric data.

Suffix

Specify the suffix to label the customized unit.

Divider

Specify the divider for the customized unit.

Thousand Separator

Choose the thousands separator for numeric data.

Decimal Separator

Choose the decimal separator for numeric data.

Decimal Places

Specify decimal places for numeric data.

Negatives

Choose the format negative numbers are displayed.

Data Formats - DateTime
Date / Time

Choose the date and time format of the data.

Custom

Customize the date and time format.

Value
A value displays a single aggregated value from a data field, e.g. total.

Chart Properties
Once you have selected a chart type, you can customize the chart by changing its properties:
Option

Description

General
Background Color

Set the background color of the chart area.

Show border

Display the outer chart border.

Border Color

Set the color of the outer chart border.

Show title

Display the chart's main title.

Title

Specify the title of the chart.

Title Font

Set the font style of the title.

Position

Set the position of the title.

Align

Set the vertical or horizontal alignment of the title.

Remarks

Enter remarks for the chart.

Data
Data Label Font

Set the font style of the data label.

Negative Font Color

Set the color of the negative value.

Align

Set the horizontal alignment of the data label.
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Data Formats - Number
Prefix

Add prefix characters to all the numeric data on the chart.

Unit

Choose the unit to shorten the numeric data.

Suffix

Specify the suffix to label the customized unit.

Divider

Specify the divider for the customized unit.

Thousand Separator

Choose the thousands separator for numeric data.

Decimal Separator

Choose the decimal separator for numeric data.

Decimal Places

Specify decimal places for numeric data.

Negatives

Choose the format negative numbers are displayed.

Data Formats - DateTime
Date / Time

Choose the date and time format of the data.

Custom

Customize the date and time format.

Trend
A trend displays that the current value is trending up or down compared to the previous value, and the percentage
change.

Chart Properties
Once you have selected a chart type, you can customize the chart by changing its properties:
Option

Description

General
Background Color

Set the background color of the chart area.

Show border

Display the outer chart border.

Border Color

Set the color of the outer chart border.

Show title

Display the chart's main title.

Title

Specify the title of the chart.

Title Font

Set the font style of the title.

Position

Set the position of the title.

Align

Set the vertical or horizontal alignment of the title.

Remarks

Enter remarks for the chart.

Data
Show previous value

Display the previous value.

Show difference

Display the Value / Percentage difference between the current value and
the previous value.

Show indicator

Display the up or down indicator.
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Main Label Font

Set the font style of the main label.

Previous Value Color

Set the color of the previous value.

Target Met Color

Set the color of the indicator and the percentage when the value is trending
up.

Target Missed Color

Set the color of the indicator and the percentage when the value is trending
down.

Data Formats - Number
Prefix

Add prefix characters to all the numeric data on the chart.

Unit

Choose the unit to shorten the numeric data.

Suffix

Specify the suffix to label the customized unit.

Divider

Specify the divider for the customized unit.

Thousand Separator

Choose the thousands separator for numeric data.

Decimal Separator

Choose the decimal separator for numeric data.

Decimal Places

Specify decimal places for numeric data.

Negatives

Choose the format negative numbers are displayed.

KPI
A KPI displays a comparison between a key value and its target value with a progress bar.

Chart Properties
Once you have selected a chart type, you can customize the chart by changing its properties:
Option

Description

General
Background Color

Set the background color of the chart area.

Show border

Display the outer chart border.

Border Color

Set the color of the outer chart border.

Show title

Display the chart's main title.

Title

Specify the title of the chart.

Title Font

Set the font style of the title.

Position

Set the position of the title.

Align

Set the vertical or horizontal alignment of the title.

Remarks

Enter remarks for the chart.

Data
Main Label Displayed

Display the Actual value or the Comparison percentage in the main label.
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Main Label Font

Set the font style of the main label.

Indicator Thickness

Set the font size of the sub-label on the bar.

Sub Label Color

Set the color of the sub-label on the bar.

Target Caption

Specify the caption of the target label.

Use custom target value

Set the target value.

Target Label Color

Set the color of the target label.

Target Met Color

Set the color of the bar when the value reaches the target.

Target Missed Color

Set the color of the bar when value does not reach the target.

Data Formats - Number
Prefix

Add prefix characters to all the numeric data on the chart.

Unit

Choose the unit to shorten the numeric data.

Suffix

Specify the suffix to label the customized unit.

Divider

Specify the divider for the customized unit.

Thousand Separator

Choose the thousands separator for numeric data.

Decimal Separator

Choose the decimal separator for numeric data.

Decimal Places

Specify decimal places for numeric data.

Negatives

Choose the format negative numbers are displayed.

Gauge
A gauge is a meter type chart. It has a circular arc and displays a single value which measures the progress toward the
target value (the goal).

Chart Properties
Once you have selected a chart type, you can customize the chart by changing its properties:
Option

Description

General
Background Color

Set the background color of the chart area.

Show border

Display the outer chart border.

Border Color

Set the color of the outer chart border.

Show title

Display the chart's main title.

Title

Specify the title of the chart.
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Title Font

Set the font style of the title.

Position

Set the position of the title.

Align

Set the vertical or horizontal alignment of the title.

Remarks

Enter remarks for the chart.

Data
Show pointer

Display the needle.

Pipe Width Percentage

Set the percentage that the scale occupies the gauge area.

Background Color

Set the background color of the scale when the needle is not displayed.

Target Color

Set the color of the target line.

Pointer Color

Set the color of the needle.

Value Display

Display the actual data or the comparison percentage of the value.

Value Font

Set the font style of the value.

Target Display

Display the actual data or the comparison percentage of the target value.

Target Caption

Specify the caption of the target label.

Use custom target value

Set the target value.

Target Font

Set the font style of the target value.

Min/Max Displayed

Display the actual data or the comparison percentages of the minimum
and maximum values.

Use custom min value

Set the value that the scale starts at.

Use custom max value

Set the value that the scale ends.

Min/Max Font

Set the font style of the minimum and maximum values.

Partition Label Displayed

Display the actual data or the comparison percentages of the partition
labels.

Partition Label Font

Set the font style of the partition labels.

Partition (Max. 8)

Divide the scale into number of partitions.

Partition Style

Divide the scale equally or custom the starting percentage of each
partition.

Data Formats - Number
Prefix

Add prefix characters to all the numeric data on the chart.

Unit

Choose the unit to shorten the numeric data.

Suffix

Specify the suffix to label the customized unit.

Divider

Specify the divider for the customized unit.

Thousand Separator

Choose the thousands separator for numeric data.

Decimal Separator

Choose the decimal separator for numeric data.

Decimal Places

Specify decimal places for numeric data.

Negatives

Choose the format negative numbers are displayed.

Table
A table represents data in a tabular view and calculates the total at the end of each column.
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Chart Properties
Once you have selected a chart type, you can customize the chart by changing its properties:
Option

Description

General
Background Color

Set the background color of the chart area.

Show border

Display the outer chart border.

Border Color

Set the color of the outer chart border.

Show title

Display the chart's main title.

Title

Specify the title of the chart.

Title Font

Set the font style of the title.

Position

Set the position of the title.

Align

Set the vertical or horizontal alignment of the title.

Remarks

Enter remarks for the chart.

Data
Font

Set the font style of the field names and data.

Show alternate row colors

Apply color to alternate rows.

Show vertical grid line

Display the vertical grid line.

Show horizontal grid line

Display the horizontal grid line.

Color

Set the color palette of the data series.

Data Formats - Number
Prefix

Add prefix characters to all the numeric data on the chart.

Unit

Choose the unit to shorten the numeric data.

Suffix

Specify the suffix to label the customized unit.

Divider

Specify the divider for the customized unit.

Thousand Separator

Choose the thousands separator for numeric data.

Decimal Separator

Choose the decimal separator for numeric data.

Decimal Places

Specify decimal places for numeric data.

Negatives

Choose the format negative numbers are displayed.

Data Formats - DateTime
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Date / Time

Choose the date and time format of the data.

Custom

Customize the date and time format.

Databar
Style

Format the cells by using data bars.

Show bar only item

Only show the data bars in the cells, without the numbers.

Custom min/max values

Customize the min and max values of the data bars.

Min value

Specify the minimum value of the data bar.

Max value

Specify the maximum value of the data bar.

Positive bar color

Set the color of the data bars with positive values.

Negative bar color

Set the color of the data bars with negative values.

Axis color

Set the color of the axis for separating the positive bar and the negative bar.

Total
Show total

Display totals in the last row of the table.

Total Color

Set the color of the total values.

Pivot Table
A pivot table shows measure values for the intersection of two dimensions and represents data in a tabular view.

Chart Properties
Once you have selected a chart type, you can customize the chart by changing its properties:
Option

Description

General
Background Color

Set the background color of the chart area.

Show border

Display the outer chart border.

Border Color

Set the color of the outer chart border.

Show title

Display the chart's main title.

Title

Specify the title of the chart.

Title Font

Set the font style of the title.

Position

Set the position of the title.

Align

Set the vertical or horizontal alignment of the title.

Remarks

Enter remarks for the chart.
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Data
Font

Set the font style of the field names and data.

Show alternate row colors

Apply color to alternate rows.

Show vertical grid line

Display the vertical grid line.

Show horizontal grid line

Display the horizontal grid line.

Color

Set the color palette of the data series.

Data Formats - Number
Prefix

Add prefix characters to all the numeric data on the chart.

Unit

Choose the unit to shorten the numeric data.

Suffix

Specify the suffix to label the customized unit.

Divider

Specify the divider for the customized unit.

Thousand Separator

Choose the thousands separator for numeric data.

Decimal Separator

Choose the decimal separator for numeric data.

Decimal Places

Specify decimal places for numeric data.

Negatives

Choose the format negative numbers are displayed.

Data Formats - DateTime
Date / Time

Choose the date and time format of the data.

Custom

Customize the date and time format.

Databar
Style

Format the cells by using data bars.

Show bar only item

Only show the data bars in the cells, without the numbers.

Custom min/max values

Customize the min and max values of the data bars.

Min value

Specify the minimum value of the data bar.

Max value

Specify the maximum value of the data bar.

Positive bar color

Set the color of the data bars with positive values.

Negative bar color

Set the color of the data bars with negative values.

Axis color

Set the color of the axis for separating the positive bar and the negative bar.

Total
Show row total

Display totals in the last row of the table.
Enter the name of the row total, and set the color of the values and the
background color.

Show column total

Display totals in the last column of the table.
Enter the name of the column total, and set the color of the values and the
background color.

Show row subtotal

Display totals in the last row of the group.
Enter the name of the row subtotal, and set the color of the values and the
background color.

Show column subtotal

Display totals in the last column of the group.
Enter the name of the column subtotal, and set the color of the values and
the background color.
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Control
A control allows you to filter the data series of all charts in the dashboard that have the same data source during the
presentation.

Chart Properties
Once you have selected a chart type, you can customize the chart by changing its properties:
Option

Description

General
Background Color

Set the background color of the chart area.

Show border

Display the outer chart border.

Border Color

Set the color of the outer chart border.

Show title

Display the chart's main title.

Title

Specify the title of the chart.

Title Font

Set the font style of the title.

Position

Set the position of the title.

Align

Set the vertical or horizontal alignment of the title.

Remarks

Enter remarks for the chart.

Data
Data Label Color

Set the color of the data label.

Style

Show the data as a list, a range or a combo box.

Data Formats - Number
Prefix

Add prefix characters to all the numeric data on the chart.

Unit

Choose the unit to shorten the numeric data.

Suffix

Specify the suffix to label the customized unit.

Divider

Specify the divider for the customized unit.

Thousand Separator

Choose the thousands separator for numeric data.

Decimal Separator

Choose the decimal separator for numeric data.
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Decimal Places

Specify decimal places for numeric data.

Negatives

Choose the format negative numbers are displayed.

Data Formats - DateTime
Date / Time

Choose the date and time format of the data.

Custom

Customize the date and time format.

DateTime Formats
The following table shows specifiers you can use to create user-defined data formats for DateTime fields in a chart.
Specifier

Description

D

Display the day as a number without a leading zero (1-31).

DD

Display the day as a number with a leading zero (01-31).

M

Display the month as a number without a leading zero (1-12).

MM

Display the month as a number with a leading zero (01-12).

MMM

Display the month as an abbreviation (Jan-Dec).

MMMM

Display the month as a full month name (January-December).

MMMMM

Display the month as a narrow name (J-D).

YY

Display the year in two-digit numeric format with a leading zero (00-99).

YYYY

Display the year in four-digit numeric format (0000-9999).

h

Display the hour as a number without a leading zero using the 12-hour
clock (1-12).

hh

Display the hour as a number with a leading zero using the 12-hour clock
(01-12).

H

Display the hour as a number without a leading zero using the 24-hour
clock (0-23).

HH

Display the hour as a number with a leading zero using the 24-hour clock
(00-23).

m

Display the minute as a number without a leading zero (0-59).

mm

Display the minute as a number with a leading zero (00-59).

S

Display the second as a number without a leading zero (0-59).

SS

Display the second as a number with a leading zero (00-59).

wd

Display the day as a single letter abbreviation (S-S).

Wd

Display the day as an abbreviation (Sun-Sat).

WD

Display the day as a full name (Sunday-Saturday).

w

Display the week of the year (1-52, start of week is Sunday).

WW

Display the week of the year (W01-W52, start of week is Sunday).

q

Display the quarter of the year (1-4).

QQ

Display the quarter of the year (Q1-Q4).

p

Display an uppercase AM with any hour before noon; display an
uppercase PM with any hour between noon and 11:59 P.M.
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Chapter 7 - Dashboard
About Dashboard
Dashboard is a collection of charts which allows you to create and view your data visualizations. When you modify a
chart, any dashboards containing it will reflect the changes.

Pages Pane
The Pages pane shows thumbnail images of each page in the dashboard. If the Pages pane is hidden, choose View ->
Show Pages from the menu bar.
Dashboard Toolbar
The Dashboard Toolbar provides controls that you can use to refresh the data and present the dashboard.
Design Pane
You can design your dashboard on the Design pane. All added objects can be moved (by dragging them with mouse or
by keyboard), resized, aligned to the grid, etc.
Properties Pane
The

Dashboard Properties tab includes the basic layout settings. The properties vary with the type of the object.

The

Using tab shows the charts and data sources that the dashboard depends on.

If the Properties pane is hidden, choose View -> Show Properties from the menu bar.

Build Dashboard
The essential steps to create a dashboard are:
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1. In the Workspace window, click

New Dashboard.

2. Enter the name of the dashboard.
3. Click OK.
4. A tab will be opened for your newly created dashboard.
5. Design your dashboard.
6. Select the properties on the right pane which can be further customized for your dashboard.
Note: Each object has different properties.
Hint: You can refresh dashboard to update data in charts with the most current data from their respective data sources.
To manually refresh the dashboard, click

Refresh Data.

Working with Grids
Show Grid
To turn the grid on in the dashboard, choose View -> Show Grid from the menu bar.
Snap to Grid
To align objects on the dashboard with the grid, choose View -> Snap to Grid from the menu bar.

Add Pages
The Pages pane shows all pages in the dashboard. It displays thumbnails of your dashboard pages.
To add a new page
1. On the Dashboard tab, click the + button on the Pages pane.
2. A blank page will be added and selected.

Properties
The available properties of a page:
Option

Description

General
Dashboard Page Size

Customize the size of pages in the dashboard.

Remarks

Enter remarks for the dashboard.

Page #
Background

Set the background color of the page. If you choose Image Fill, you can
choose the image file and the scaling option.
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Opacity

Set the opacity of the image.

Page Note

Enter the reference, comment, or explanation of the page.

Add Charts
Charts provide visual representations of the data in your data source.
To add a chart
1. On the Dashboard tab, click

Add Chart.

2. All available charts in the workspace will be shown as thumbnails. If no charts are available, click
Chart to create one. For detailed instructions on creating charts, see Build Charts.
3. Drag a chart to the Design pane.

Properties
The available properties of a chart:
Option

Description

Position

Customize the position of the chart.

Size

Customize the size of the chart.

Add Text Labels
Text labels are typically used to help document the dashboard, such as adding a dashboard title, URL links.
To add a text label
1. On the Dashboard tab, click

Add Text.

2. Place it on the dashboard.
3. Enter the caption.

Properties
The available properties of a text label:
Option

Description

Position

Customize the position of the label.

Size

Customize the size of the label.

Caption

Enter the caption of the label.

Horizontal Alignment /

Specify the text alignment of the label caption.

Vertical Alignment
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New

Padding

Set the horizontal and vertical padding for the text.

Font

Set the font style of the label caption.

Bold

Apply a bold style to the label caption.

Italic

Apply an italic style to the label caption.

Background Color

Set the background color of the label.

URL

Enter URL path to set the text as a hyperlink.

Add Images
You can insert images (BMP, JPG, JPEG or PNG files) to your dashboard for design or identification purposes.
To add an image
1. On the Dashboard tab, click

Add Image.

2. Select an image file in the Open dialog box.

Properties
The available properties of an image:
Option

Description

Opacity

Set the opacity of the image.

Position

Customize the position of the image.

Size

Customize the size of the image.

Original Size

Reset the image to its original size.

URL

Enter URL path to set the image as a hyperlink.

Add Shapes
Navicat Charts Creator includes some pre-defined shapes for creating a dashboard: line, arrow, rectangle, ellipse,
database, cloud, trigger, server, desktop, mobile, man, woman.
To add a shape
1. On the Dashboard tab, click

Add Shape and choose a shape type.

2. Place it on the dashboard.
To add a vertex on a line or an arrow
1. Select a line or an arrow on the dashboard.
2. Press and hold the SHIFT key and click on it.
To delete a vertex on a line or an arrow
98

1. Select a line or an arrow on the dashboard.
2. Press and hold the SHIFT key and click on the vertex.

Properties
The available properties of a shape:
Option

Description

Position

Customize the position of the shape.

Size

Customize the size of the shape.
Only for rectangle, ellipse, database, cloud, trigger, server, desktop,
mobile, man and woman.

Color

Set the color of the shape.

Show border

Display the outer shape border.
Only for rectangle, ellipse, database, cloud, trigger, server, desktop,
mobile, man and woman.

Border Color

Change the color of the shape's border.
Only for rectangle, ellipse, database, cloud, trigger, server, desktop,
mobile, man and woman.

Border Width

Choose the thickness of the border.
Only for rectangle, ellipse, database, cloud, trigger, server, desktop, mobile,
man and woman.

Line Width

Choose the thickness of the shape.

Cap Style

Choose the cap style of the line/arrow.

Dash Style

Choose the dash style of the line/arrow.

Join Style

Choose the join style of the line/arrow.

Begin Arrow Style

Choose the style of the arrow's back.

End Arrow Style

Choose the style of the arrow's front.

Arrange Objects
You can arrange the objects on a dashboard page in the following ways:
•

Move objects forward and backward to layer them.

•

Align an object with other objects.

•

Distribute the objects horizontally or vertically.

•

Group objects to more easily move them as a single unit and synchronize the axis of the related charts.

•

Lock objects to prevent them from moving, modifying, or deleting.

Move Objects Forward / Backward
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To send an object to the back of the dashboard, right-click it and select Send to Back.
To bring an object to the front of the dashboard, right-click it and select Bring to Front.

Align Objects
Select multiple objects, then right-click and select Alignment -> Align Left, Align Center, Align Right, Align Top,
Align Middle or Align Bottom.

Change Objects Distribution
Select multiple objects, then right-click and select Distribute -> Horizontal or Vertical.

Group Objects
Select multiple objects, then click Group on the Properties pane and enable the following properties if necessary.
Option

Description

Link Scrolling

Synchronize the scrollbar of all charts.

Link Highlight

Hover over a data point on one of the charts will highlight the same data
points on the others.

Show Hints When

Pop up the hint labels when hovering over a data point on one of the charts.

Highlight
Ungroup Objects
Select the group, then click Ungroup on the Properties pane.

Lock Objects
Select an object, then click Lock on the Properties pane.

Unlock Objects
Select the locked object, then click Unlock on the Properties pane.

Present Dashboard
You can present the dashboard using the whole screen. The title bar, toolbar, tab bar, Pages pane, Control List and
Properties pane will be hidden while in this mode. To open a dashboard in present view, click

Present.

If you have added a control chart to your dashboard, you can filter the data series of all charts by using the control.
To exit present view, press the ESC key and the workspace window will be returned to its previous state.

Sort Chart
In the Present mode, you can organize your data in a chart with one click. You can sort data series by a value.
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1. Hover over a chart until you see the
2. Click the

icon in the upper-right corner.

icon to sort on a different value and select the sorting order.

Print & Export Dashboard
Print to a printer
Choose File -> Print to send your dashboard pages directly to the printer. You can set the printer option in the pop-up
window.
Export to a file
Choose File -> Export To and choose the file format to create a PDF, PNG, SVG or JPG file of your dashboard pages.
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Chapter 8 - Other Advanced Tools
Useful Features
Navicat Charts Creator provides variety of tools that improve user experience when working on workspaces.
•

Switch Theme

•

Search Filter

•

Dark Theme

Switch Theme
Charts and dashboards are not affected by the software theme selected in Options. If you want use a Dark theme for
your charts, click

Switch Theme to change the theme.

Search Filter
Navicat Charts Creator provides search filters for searching your objects in the main window and tree structures.
In the main window, enter a search string in the

Search text box.

In the tree structures, click on the tree to focus and enter a search string directly.
You can remove the filter by deleting the search string.
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Dark Theme
In Dark Theme, Navicat Charts Creator uses a darker color palette for all windows, views, menus, and controls. It works
on all supported versions of Windows.
To change your theme, choose Tools -> Options -> General. Then, select Dark.
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Chapter 9 - Configurations
Options Settings
Navicat Charts Creator provides several options for customizing its user interface and performance.
To open the Options window, choose Tools -> Options from the menu bar.

General
General
Theme
Choose to use the theme of your Windows OS or a Dark theme.
Hint: Restart Navicat Charts Creator to take effect.
Show toolbar caption
Show text on toolbar buttons in workspace windows. Otherwise, only buttons will be presented.
Hint: Restart Navicat Charts Creator to take effect.

Use safe confirm dialog (Main Window)
With this option is on, Navicat Charts Creator will prompt a double confirmation dialog for safe deletion when deleting
objects in the main window.
Check for updates on startup
Check this option to allow Navicat Charts Creator checks for new version when it starts.

Usage Data
Share Usage Data
Check this option to let your device sends us information about how you use Navicat Charts Creator to help us improve
it. You can view the information being shared by clicking the Usage Data button.

Code Completion
Use code completion
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When you type the . (dot) symbol or a character, the editor will offer you a pop-up list that showing some suggestions
for the code completion.
Auto update code completion info
With this option is on, Navicat Charts Creator will get the latest database information for code completion from your
server automatically when you open the database/schema.
Auto select first suggestion
Select the first item automatically when the suggestion list pops up. Therefore, pressing ENTER or TAB will insert the
selected item. Otherwise, you need to use arrow keys to select the suggestion item.
Clear Code Completion Info
Delete the information for code completion feature that stored on your device.

Editor
General
Show line number
Display line numbers at the left side of the editor for easily reference.
Use code folding
Code folding allows codes to collapse as a block and only the first line displayed in the editor.
Use brace highlighting
Highlight the pair of braces when your cursor moves to either one brace for easily reference.
Use syntax highlighting
Syntax highlight helps viewing codes clearly. Codes are highlighted in the editor with different colors and fonts
according to the categories they belong to. This feature can be limited by setting the maximum file size (e.g. 10) in
Disable if file size is larger than (MB) to increase performance.
Use word wrap
Enable the word wrap mode in the editor.
Tab Width
Enter the number of characters that a tab occupies, e.g. 5.
See Query Editor.
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Font and Colors
Editor Font
Define the font and its size used by editors.
Colors
Format your queries in the editor with colored syntax highlighting to improve readability. Set font colors to mark out
different text fragments: Common, Keyword, String, Number, Comment and Background. Click on the color boxes and
choose your desired color from the Color-Selection dialog window.

Records
Records
Limit records

records per page

Check this option if you want to limit the number of records showed on each page in the data grid globally. Otherwise,
all records will be displayed in one single page.
Note: To adjust the settings for particular data grid, see View Data.

Grid
Grid Font
Define the font and its size used by grid in Data Viewer.
Row Shading
Apply shading to alternate rows or every third row in the grid for viewing data clearly. Choose None if you do not want
to apply shading.

Auto Recovery
Charts
Save automatically after modifications in workspaces by defining the Auto Save Interval (seconds) (e.g. 30).

File Locations
Logs Location
Navicat Charts Creator provides number of log files to keep track on the actions have been performed in Navicat
Charts Creator and they are located in the Logs Location path.
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Profiles Location
The internal files of Navicat Charts Creator are located in the Profiles Location path.

Connectivity
General
Verify server certificate against CA
Enable this option to verify that the server certificate against the list of trusted CA.

Proxy
Enable the Use proxy option to configure Navicat Charts Creator to use proxy in order to make its network
connections.
Proxy Type
Specify the type of your proxy server: HTTP or SOCKS5.
Host
The host name of your proxy server.
Port
The port number of your proxy server.
User Name / Password
If your proxy server requires authentication, you can enter a username and a password.

Connectivity Diagnosis
Click Test Connectivity to test the network connectivity between the web service and your machine.

Environment
OCI Environment
OCI library (oci.dll)
Specify the location for the OCI library (oci.dll) for Oracle connection. By default, it is set to the bundled one in Navicat
Charts Creator installation folder.
Hint: Restart Navicat Charts Creator to take effect.
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Oracle Instant Client is the simplest way to deploy a full Oracle Client application built with OCI, OCCI, JDBC-OCI, or
ODBC drivers. It provides the necessary Oracle Client libraries in a small set of files. You can also download Oracle
Client / Oracle Instant Client through Oracle Client
Oracle Instant Client
Download the appropriate Instant Client packages for your platform and the CPU. All installations REQUIRE the Basic
or Basic Lite package. Unzip the packages and set the path points to it.

Advanced
Enable diagnostic logging
Generate a log file in Logs Location to assist with tracking down any problems in Navicat Charts Creator.
Hint: Restart Navicat Charts Creator to take effect.
Register on "Open with" List
Register Navicat Charts Creator program to the "Open with" list in Windows.
Register Navicat URI Protocol
Register Navicat URI protocol in Windows. When clicking a Navicat URI link, Navicat Charts Creator opens and adds the
corresponding Navicat On-Prem Server using the parameters in the URI.
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Chapter 10 - Hot Keys
Charts Creator Hot Keys
Keys

Action

CTRL+S

Save

CTRL+SHIFT+S

Save As

F11

Present Dashboard

F5

Refresh Data

CTRL+P

Print Dashboard

CTRL+TAB

Next Window
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Chapter 11 - Trace Logs
Log Files
Navicat Charts Creator provides number of log files to keep track on the actions have been performed in Navicat
Charts Creator and they are located in the logs directory, e.g. C:\Users\Guest\Documents\Navicat Charts Creator\logs\.
You are allowed to change the log files location under Options.
File

Description

history.log

Store the statements or scripts of all operations executed over databases
and database objects in Navicat Charts Creator.
Note: This log will be overwritten while Navicat Charts Creator is being
restarted.

navicat.log

Store information to assist with tracking down any problems in Navicat
Charts Creator. You can enable this log in Options.
Note: This log will be overwritten while Navicat Charts Creator is being
restarted.
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